summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2023-02-06 10:46:22 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2023-02-06 19:52:35 +0100
commitd4d1313417879534462861be2ecf831a57f1a7a6 (patch)
tree535b321b9ea9c2b95435dbda958011cb5aedff99 /pyproject.toml
parent11f7a4f5826d0bf1b1d1325ed49c6c91127c695e (diff)
downloadpylint-git-d4d1313417879534462861be2ecf831a57f1a7a6.tar.gz
[pre-commit] Add ruff to the pre-commit configuration
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 3fa73da29..f184d9398 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -130,3 +130,11 @@ module = [
"pytest",
"sphinx.*",
]
+[tool.ruff]
+select = ["E", "F", "B"]
+ignore = [
+ "F841", # False positive for typing
+ "B905", # Not enforced previousely
+]
+fixable = ["E", "F", "B"]
+line-length = 125