summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorMarc Mueller <30130371+cdce8p@users.noreply.github.com>2022-06-28 23:39:17 +0200
committerGitHub <noreply@github.com>2022-06-28 23:39:17 +0200
commit0d36a63303eb902de3c33a6094260bc385681d2d (patch)
tree961e617cb583d24204d6d6ef7dfd6c81d4e214ae /setup.cfg
parentc74493bdb969c40b0b9bc503b239c572ee31641b (diff)
downloadpylint-git-0d36a63303eb902de3c33a6094260bc385681d2d.tar.gz
Improve packaging [PEP 517 + 621] (#7076)
* Use isolated build environments * Update release ci job to use build * Use new project metadata format * Cleanup MANIFEST.in * Remove setup.py
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg85
1 files changed, 15 insertions, 70 deletions
diff --git a/setup.cfg b/setup.cfg
index e2b157d44..2c13527cb 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,77 +1,12 @@
+# Setuptools v62.6 doesn't support editable installs with just 'pyproject.toml' (PEP 660).
+# Keep this file until it does!
+
[metadata]
-name = pylint
-version = attr: pylint.__pkginfo__.__version__
-description = python code static checker
-long_description = file: README.rst
-long_description_content_type = text/x-rst
-author = Python Code Quality Authority
-author_email = code-quality@python.org
-license = GPL-2.0-or-later
+# wheel doesn't yet read license_files from pyproject.toml - tools.setuptools
+# Keep it here until it does!
license_files =
LICENSE
CONTRIBUTORS.txt
-classifiers =
- Development Status :: 6 - Mature
- Environment :: Console
- Intended Audience :: Developers
- License :: OSI Approved :: GNU General Public License v2 (GPLv2)
- Operating System :: OS Independent
- Programming Language :: Python
- Programming Language :: Python :: 3
- Programming Language :: Python :: 3 :: Only
- Programming Language :: Python :: 3.7
- Programming Language :: Python :: 3.8
- Programming Language :: Python :: 3.9
- Programming Language :: Python :: 3.10
- Programming Language :: Python :: Implementation :: CPython
- Programming Language :: Python :: Implementation :: PyPy
- Topic :: Software Development :: Debuggers
- Topic :: Software Development :: Quality Assurance
- Topic :: Software Development :: Testing
-keywords = static code analysis linter python lint
-project_urls =
- Docs: User Guide = https://pylint.pycqa.org/en/latest/
- Source Code = https://github.com/PyCQA/pylint
- What's New = https://pylint.pycqa.org/en/latest/whatsnew/2/
- Bug Tracker = https://github.com/PyCQA/pylint/issues
- Discord Server = https://discord.com/invite/Egy6P8AMB5
- Docs: Contributer Guide = https://pylint.pycqa.org/en/latest/development_guide/contributor_guide/index.html
-
-[options]
-packages = find:
-install_requires =
- dill>=0.2
- platformdirs>=2.2.0
- # Also upgrade requirements_test_min.txt if you are bumping astroid.
- # Pinned to dev of next minor update to allow editable installs,
- # see https://github.com/PyCQA/astroid/issues/1341
- astroid>=2.11.6,<=2.12.0-dev0
- isort>=4.2.5,<6
- mccabe>=0.6,<0.8
- tomli>=1.1.0;python_version<"3.11"
- tomlkit>=0.10.1
- colorama>=0.4.5;sys_platform=="win32"
- typing-extensions>=3.10.0;python_version<"3.10"
-python_requires = >=3.7.2
-
-[options.extras_require]
-testutils=gitpython>3
-spelling=pyenchant~=3.2
-
-[options.packages.find]
-include =
- pylint*
-
-[options.entry_points]
-console_scripts =
- pylint = pylint:run_pylint
- pylint-config = pylint:_run_pylint_config
- epylint = pylint:run_epylint
- pyreverse = pylint:run_pyreverse
- symilar = pylint:run_symilar
-
-[options.package_data]
-pylint = testutils/testing_pylintrc
[aliases]
test = pytest
@@ -93,6 +28,16 @@ known_third_party = platformdirs, astroid, sphinx, isort, pytest, mccabe, six, t
skip_glob = tests/functional/**,tests/input/**,tests/extensions/data/**,tests/regrtest_data/**,tests/data/**,astroid/**,venv/**
src_paths = pylint
+[flake8]
+ignore =
+ E203, W503, # Incompatible with black see https://github.com/ambv/black/issues/315
+ E501, # Lot of lines too long right now
+max-line-length=88
+max-complexity=39
+# Required for flake8-typing-imports (v1.12.0)
+# The plugin doesn't yet read the value from pyproject.toml
+min_python_version = 3.7.2
+
[mypy]
no_implicit_optional = True
scripts_are_modules = True