summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorChristian Clauss <cclauss@me.com>2022-09-22 13:23:08 +0200
committerDaniƫl van Noord <13665637+DanielNoord@users.noreply.github.com>2022-09-22 20:22:31 +0200
commitd2056b3a675183f1165c8c8153302a7572bead97 (patch)
tree279f85de7b6df4bd257ef2c58b7340e6a12bdfa9 /setup.cfg
parentea86fcf71af6f2e39ce1fdcab5f8bf05b4d32082 (diff)
downloadpylint-git-d2056b3a675183f1165c8c8153302a7572bead97.tar.gz
Migrate configs for isort, mypy, and pytest into pyproject.toml
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg65
1 files changed, 0 insertions, 65 deletions
diff --git a/setup.cfg b/setup.cfg
index 492c3f990..43de692ae 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -8,26 +8,6 @@ license_files =
LICENSE
CONTRIBUTORS.txt
-[aliases]
-test = pytest
-
-[tool:pytest]
-testpaths = tests
-python_files = *test_*.py
-addopts = --strict-markers
-markers =
- primer_stdlib: Checks for crashes and errors when running pylint on stdlib
- primer_external_batch_one: Checks for crashes and errors when running pylint on external libs (batch one)
- benchmark: Baseline of pylint performance, if this regress something serious happened
- timeout: Marks from pytest-timeout.
- needs_two_cores: Checks that need 2 or more cores to be meaningful
-
-[isort]
-profile = black
-known_third_party = platformdirs, astroid, sphinx, isort, pytest, mccabe, six, toml
-skip_glob = tests/functional/**,tests/input/**,tests/extensions/data/**,tests/regrtest_data/**,tests/data/**,astroid/**,venv/**
-src_paths = pylint
-
[flake8]
ignore =
E203, W503, # Incompatible with black see https://github.com/ambv/black/issues/315
@@ -37,48 +17,3 @@ max-complexity=39
# Required for flake8-typing-imports (v1.12.0)
# The plugin doesn't yet read the value from pyproject.toml
min_python_version = 3.7.2
-
-[mypy]
-scripts_are_modules = True
-warn_unused_ignores = True
-show_error_codes = True
-enable_error_code = ignore-without-code
-strict = True
-# TODO: Remove this once pytest has annotations
-disallow_untyped_decorators = False
-
-[mypy-astroid.*]
-ignore_missing_imports = True
-
-[mypy-contributors_txt]
-ignore_missing_imports = True
-
-[mypy-coverage]
-ignore_missing_imports = True
-
-[mypy-enchant.*]
-ignore_missing_imports = True
-
-[mypy-mccabe]
-ignore_missing_imports = True
-
-[mypy-pytest]
-ignore_missing_imports = True
-
-[mypy-_pytest.*]
-ignore_missing_imports = True
-
-[mypy-pytest_benchmark.*]
-ignore_missing_imports = True
-
-[mypy-_string]
-ignore_missing_imports = True
-
-[mypy-git.*]
-ignore_missing_imports = True
-
-[mypy-sphinx.*]
-ignore_missing_imports = True
-
-[mypy-dill]
-ignore_missing_imports = True