summaryrefslogtreecommitdiff
path: root/tbump.toml
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-05-10 11:18:32 +0200
committerGitHub <noreply@github.com>2022-05-10 11:18:32 +0200
commit133e2e59394528e3c2c16fd7ea921796bfcbef8d (patch)
tree9f2afc2001bb0760625e004f6594b9bc7be770e2 /tbump.toml
parent0199504334bf1313854bdbc42f6982484f77cbbd (diff)
downloadpylint-git-133e2e59394528e3c2c16fd7ea921796bfcbef8d.tar.gz
Upgrade configuration example and add toml example (#6529)
* Add a pyproject.toml example and an automated upgrade for release * Upgrade the pylintrc example following migration to argparse
Diffstat (limited to 'tbump.toml')
-rw-r--r--tbump.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/tbump.toml b/tbump.toml
index 27a7db71a..773efeea5 100644
--- a/tbump.toml
+++ b/tbump.toml
@@ -37,6 +37,10 @@ name = "Upgrade the pylintrc examples"
cmd = "pylint --rcfile=/dev/null --generate-rcfile > examples/pylintrc"
[[before_commit]]
+name = "Upgrade the toml examples"
+cmd = "pylint --rcfile=/dev/null --generate-toml-config > examples/pyproject.toml"
+
+[[before_commit]]
name = "Normalize the contributors-txt configuration"
cmd = "contributors-txt-normalize-configuration -a script/.contributors_aliases.json -o script/.contributors_aliases.json"