summaryrefslogtreecommitdiff
path: root/tests/testutils
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-03-01 16:04:49 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2022-03-24 13:06:15 +0100
commitec4a3f7f1eac9e605b35d1ac56680e1608c48be3 (patch)
tree5cf16665b7797bbe17e71f0f886a744e83bd034a /tests/testutils
parent9e0baf370a15fecf3360996a6a2ead688fc61894 (diff)
downloadpylint-git-ec4a3f7f1eac9e605b35d1ac56680e1608c48be3.tar.gz
Add a pre-commit hook to check the copyright notice
Fix the existing file so they have a notice. No header for setup.py or examples or doc
Diffstat (limited to 'tests/testutils')
-rw-r--r--tests/testutils/dummy_checker.py3
-rw-r--r--tests/testutils/test_configuration_test.py4
-rw-r--r--tests/testutils/test_decorator.py3
-rw-r--r--tests/testutils/test_functional_testutils.py2
-rw-r--r--tests/testutils/test_lint_module_output_update.py2
-rw-r--r--tests/testutils/test_output_line.py2
-rw-r--r--tests/testutils/test_package_to_lint.py2
7 files changed, 12 insertions, 6 deletions
diff --git a/tests/testutils/dummy_checker.py b/tests/testutils/dummy_checker.py
index e69de29bb..e8a8ff79f 100644
--- a/tests/testutils/dummy_checker.py
+++ b/tests/testutils/dummy_checker.py
@@ -0,0 +1,3 @@
+# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
+# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
diff --git a/tests/testutils/test_configuration_test.py b/tests/testutils/test_configuration_test.py
index 195c4415c..2efa65df3 100644
--- a/tests/testutils/test_configuration_test.py
+++ b/tests/testutils/test_configuration_test.py
@@ -1,3 +1,7 @@
+# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
+# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
+
import logging
from pathlib import Path
diff --git a/tests/testutils/test_decorator.py b/tests/testutils/test_decorator.py
index 64594b39c..42b88ab5c 100644
--- a/tests/testutils/test_decorator.py
+++ b/tests/testutils/test_decorator.py
@@ -1,7 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
-
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
import pytest
diff --git a/tests/testutils/test_functional_testutils.py b/tests/testutils/test_functional_testutils.py
index 136bda749..f37ffb1ca 100644
--- a/tests/testutils/test_functional_testutils.py
+++ b/tests/testutils/test_functional_testutils.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
"""Tests for the functional test framework."""
diff --git a/tests/testutils/test_lint_module_output_update.py b/tests/testutils/test_lint_module_output_update.py
index 332463b03..6d46f84b4 100644
--- a/tests/testutils/test_lint_module_output_update.py
+++ b/tests/testutils/test_lint_module_output_update.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
# pylint: disable=redefined-outer-name
from pathlib import Path
diff --git a/tests/testutils/test_output_line.py b/tests/testutils/test_output_line.py
index 6a0e35518..6e6335ecc 100644
--- a/tests/testutils/test_output_line.py
+++ b/tests/testutils/test_output_line.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
# pylint: disable=redefined-outer-name
diff --git a/tests/testutils/test_package_to_lint.py b/tests/testutils/test_package_to_lint.py
index a79faa60c..c3d2a4ab4 100644
--- a/tests/testutils/test_package_to_lint.py
+++ b/tests/testutils/test_package_to_lint.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
from pylint.testutils.primer import PRIMER_DIRECTORY_PATH, PackageToLint