summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CONTRIBUTORS.txt2
-rw-r--r--doc/user_guide/checkers/features.rst3
-rw-r--r--doc/user_guide/configuration/all-options.rst2
-rw-r--r--doc/whatsnew/2/2.14/full.rst8
-rw-r--r--examples/pylintrc3
-rw-r--r--examples/pyproject.toml3
-rw-r--r--pylint/__pkginfo__.py2
-rw-r--r--tbump.toml2
8 files changed, 18 insertions, 7 deletions
diff --git a/CONTRIBUTORS.txt b/CONTRIBUTORS.txt
index e6c4ffd54..1fc26311e 100644
--- a/CONTRIBUTORS.txt
+++ b/CONTRIBUTORS.txt
@@ -401,6 +401,7 @@ contributors:
- Matthijs Blom <19817960+MatthijsBlom@users.noreply.github.com>
- Matej Marušák <marusak.matej@gmail.com>
- Markus Siebenhaar <41283549+siehar@users.noreply.github.com>
+- Marco Pernigotti <7657251+mpernigo@users.noreply.github.com>
- Marco Edward Gorelli <marcogorelli@protonmail.com>: Documented Jupyter integration
- Marcin Kurczewski <rr-@sakuya.pl> (rr-)
- Maik Röder <maikroeder@gmail.com>
@@ -489,6 +490,7 @@ contributors:
- Caio Carrara <ccarrara@redhat.com>
- C.A.M. Gerlach <WIDEnetServices@gmail.com>
- Bruno P. Kinoshita <kinow@users.noreply.github.com>
+- Bruce Dawson <randomascii@users.noreply.github.com>
- Brian C. Lane <bcl@redhat.com>
- Brandon W Maister <quodlibetor@gmail.com>
- BioGeek <jeroen.vangoey@gmail.com>
diff --git a/doc/user_guide/checkers/features.rst b/doc/user_guide/checkers/features.rst
index d410c119b..741a7d30f 100644
--- a/doc/user_guide/checkers/features.rst
+++ b/doc/user_guide/checkers/features.rst
@@ -41,7 +41,8 @@ General options
specified are enabled, while categories only check already-enabled messages.
:jobs:
Use multiple processes to speed up Pylint. Specifying 0 will auto-detect the
- number of processors available to use.
+ number of processors available to use, and will cap the count on Windows to
+ avoid hangs.
Default: ``1``
:unsafe-load-any-extension:
diff --git a/doc/user_guide/configuration/all-options.rst b/doc/user_guide/configuration/all-options.rst
index 89b7a1ca9..cb8d86db5 100644
--- a/doc/user_guide/configuration/all-options.rst
+++ b/doc/user_guide/configuration/all-options.rst
@@ -165,7 +165,7 @@ Default:
""""""
Description:
- *Use multiple processes to speed up Pylint. Specifying 0 will auto-detect the number of processors available to use.*
+ *Use multiple processes to speed up Pylint. Specifying 0 will auto-detect the number of processors available to use, and will cap the count on Windows to avoid hangs.*
Default:
``1``
diff --git a/doc/whatsnew/2/2.14/full.rst b/doc/whatsnew/2/2.14/full.rst
index 34ebdc50c..7a743eaa4 100644
--- a/doc/whatsnew/2/2.14/full.rst
+++ b/doc/whatsnew/2/2.14/full.rst
@@ -1,10 +1,16 @@
Full changelog
==============
-What's New in Pylint 2.14.4?
+What's New in Pylint 2.14.5?
----------------------------
Release date: TBA
+
+
+What's New in Pylint 2.14.4?
+----------------------------
+Release date: 2022-06-29
+
* The ``differing-param-doc`` check was triggered by positional only arguments.
Closes #6950
diff --git a/examples/pylintrc b/examples/pylintrc
index 61528a5bb..8199d6d5a 100644
--- a/examples/pylintrc
+++ b/examples/pylintrc
@@ -64,7 +64,8 @@ ignored-modules=
#init-hook=
# Use multiple processes to speed up Pylint. Specifying 0 will auto-detect the
-# number of processors available to use.
+# number of processors available to use, and will cap the count on Windows to
+# avoid hangs.
jobs=1
# Control the amount of potential inferred values when inferring a single
diff --git a/examples/pyproject.toml b/examples/pyproject.toml
index 138907a68..5e19f11c6 100644
--- a/examples/pyproject.toml
+++ b/examples/pyproject.toml
@@ -53,7 +53,8 @@ ignore-patterns = ["^\\.#"]
# init-hook =
# Use multiple processes to speed up Pylint. Specifying 0 will auto-detect the
-# number of processors available to use.
+# number of processors available to use, and will cap the count on Windows to
+# avoid hangs.
jobs = 1
# Control the amount of potential inferred values when inferring a single object.
diff --git a/pylint/__pkginfo__.py b/pylint/__pkginfo__.py
index 83e09584c..ebb399224 100644
--- a/pylint/__pkginfo__.py
+++ b/pylint/__pkginfo__.py
@@ -9,7 +9,7 @@ It's updated via tbump, do not modify.
from __future__ import annotations
-__version__ = "2.14.3"
+__version__ = "2.14.4"
def get_numversion_from_version(v: str) -> tuple[int, int, int]:
diff --git a/tbump.toml b/tbump.toml
index 1597ff765..309b87dc6 100644
--- a/tbump.toml
+++ b/tbump.toml
@@ -1,7 +1,7 @@
github_url = "https://github.com/PyCQA/pylint"
[version]
-current = "2.14.3"
+current = "2.14.4"
regex = '''
^(?P<major>0|[1-9]\d*)
\.