summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/backport.yml2
-rw-r--r--pyproject.toml6
-rw-r--r--requirements_test_min.txt2
3 files changed, 4 insertions, 6 deletions
diff --git a/.github/workflows/backport.yml b/.github/workflows/backport.yml
index 762c5d6ee..4c2639b50 100644
--- a/.github/workflows/backport.yml
+++ b/.github/workflows/backport.yml
@@ -7,7 +7,7 @@ on:
permissions:
pull-requests: write
- content: write
+ contents: write
jobs:
backport:
diff --git a/pyproject.toml b/pyproject.toml
index 401106a3b..0dadcf6c3 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -33,14 +33,12 @@ classifiers = [
]
requires-python = ">=3.7.2"
dependencies = [
- # TODO: Remove dill-pylint once dill 0.3.6 is released
- "dill>=0.2;python_version<'3.11'",
- "dill-pylint>=0.3.6.dev0;python_version>='3.11'",
+ "dill>=0.2",
"platformdirs>=2.2.0",
# Also upgrade requirements_test_min.txt.
# Pinned to dev of second minor update to allow editable installs and fix primer issues,
# see https://github.com/PyCQA/astroid/issues/1341
- "astroid>=2.12.12,<=2.14.0-dev0",
+ "astroid>=2.12.13,<=2.14.0-dev0",
"isort>=4.2.5,<6",
"mccabe>=0.6,<0.8",
"tomli>=1.1.0;python_version<'3.11'",
diff --git a/requirements_test_min.txt b/requirements_test_min.txt
index 77dd54a95..9569d9a29 100644
--- a/requirements_test_min.txt
+++ b/requirements_test_min.txt
@@ -1,6 +1,6 @@
-e .[testutils,spelling]
# astroid dependency is also defined in pyproject.toml
-astroid==2.12.12 # Pinned to a specific version for tests
+astroid==2.12.13 # Pinned to a specific version for tests
typing-extensions~=4.4
py~=1.11.0
pytest~=7.2