summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitattributes5
-rw-r--r--doc/data/messages/c/consider-ternary-expression/bad.py10
-rw-r--r--doc/data/messages/c/consider-ternary-expression/pylintrc4
-rw-r--r--doc/data/messages/c/consider-using-ternary/bad.py4
-rw-r--r--doc/data/messages/d/disallowed-name/bad.py2
-rw-r--r--doc/data/messages/e/else-if-used/bad.py12
-rw-r--r--doc/data/messages/e/else-if-used/pylintrc2
-rw-r--r--doc/data/messages/i/import-error/details.rst6
-rw-r--r--doc/data/messages/i/import-self/bad.py10
-rw-r--r--doc/data/messages/l/logging-format-interpolation/details.rst2
-rw-r--r--doc/data/messages/l/logging-fstring-interpolation/details.rst2
-rw-r--r--doc/data/messages/u/use-a-generator/details.rst4
-rw-r--r--doc/data/messages/u/use-dict-literal/details.rst8
-rw-r--r--doc/data/messages/u/using-final-decorator-in-unsupported-version/bad.py16
-rw-r--r--doc/data/messages/u/using-final-decorator-in-unsupported-version/good.py6
15 files changed, 49 insertions, 44 deletions
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000..a3a7609a7
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1,5 @@
+* text=auto
+tests/**/functional/** -text
+tests/input/** -text
+tests/**/data/** -text
+tests/regrtest_data/** -text
diff --git a/doc/data/messages/c/consider-ternary-expression/bad.py b/doc/data/messages/c/consider-ternary-expression/bad.py
index 741784481..126b92b0e 100644
--- a/doc/data/messages/c/consider-ternary-expression/bad.py
+++ b/doc/data/messages/c/consider-ternary-expression/bad.py
@@ -1,5 +1,5 @@
-x, y = input(), input()
-if x >= y: # [consider-ternary-expression]
- maximum = x
-else:
- maximum = y
+x, y = input(), input()
+if x >= y: # [consider-ternary-expression]
+ maximum = x
+else:
+ maximum = y
diff --git a/doc/data/messages/c/consider-ternary-expression/pylintrc b/doc/data/messages/c/consider-ternary-expression/pylintrc
index 814b5ece4..20f7725cd 100644
--- a/doc/data/messages/c/consider-ternary-expression/pylintrc
+++ b/doc/data/messages/c/consider-ternary-expression/pylintrc
@@ -1,2 +1,2 @@
-[MAIN]
-load-plugins=pylint.extensions.consider_ternary_expression
+[MAIN]
+load-plugins=pylint.extensions.consider_ternary_expression
diff --git a/doc/data/messages/c/consider-using-ternary/bad.py b/doc/data/messages/c/consider-using-ternary/bad.py
index 39a790f86..bd69aa99e 100644
--- a/doc/data/messages/c/consider-using-ternary/bad.py
+++ b/doc/data/messages/c/consider-using-ternary/bad.py
@@ -1,2 +1,2 @@
-x, y = 1, 2
-maximum = x >= y and x or y # [consider-using-ternary]
+x, y = 1, 2
+maximum = x >= y and x or y # [consider-using-ternary]
diff --git a/doc/data/messages/d/disallowed-name/bad.py b/doc/data/messages/d/disallowed-name/bad.py
index c2e3fc499..11d033a0a 100644
--- a/doc/data/messages/d/disallowed-name/bad.py
+++ b/doc/data/messages/d/disallowed-name/bad.py
@@ -1,2 +1,2 @@
-def foo(): # [disallowed-name]
+def foo(): # [disallowed-name]
pass
diff --git a/doc/data/messages/e/else-if-used/bad.py b/doc/data/messages/e/else-if-used/bad.py
index 93a41f6f4..55cf422ac 100644
--- a/doc/data/messages/e/else-if-used/bad.py
+++ b/doc/data/messages/e/else-if-used/bad.py
@@ -1,7 +1,7 @@
-if input():
- pass
-else:
- if len(input()) >= 10: # [else-if-used]
- pass
- else:
+if input():
+ pass
+else:
+ if len(input()) >= 10: # [else-if-used]
+ pass
+ else:
pass
diff --git a/doc/data/messages/e/else-if-used/pylintrc b/doc/data/messages/e/else-if-used/pylintrc
index 3c1cb2543..5c438919e 100644
--- a/doc/data/messages/e/else-if-used/pylintrc
+++ b/doc/data/messages/e/else-if-used/pylintrc
@@ -1,2 +1,2 @@
-[MAIN]
+[MAIN]
load-plugins=pylint.extensions.check_elif
diff --git a/doc/data/messages/i/import-error/details.rst b/doc/data/messages/i/import-error/details.rst
index a9f539ae4..aaa3edc11 100644
--- a/doc/data/messages/i/import-error/details.rst
+++ b/doc/data/messages/i/import-error/details.rst
@@ -1,3 +1,3 @@
-This can happen if you're importing a package that is not installed in your environment, or if you made a typo.
-
-The solution is to install the package via pip/setup.py/wheel or fix the typo.
+This can happen if you're importing a package that is not installed in your environment, or if you made a typo.
+
+The solution is to install the package via pip/setup.py/wheel or fix the typo.
diff --git a/doc/data/messages/i/import-self/bad.py b/doc/data/messages/i/import-self/bad.py
index 60f1c968d..8783a0ca8 100644
--- a/doc/data/messages/i/import-self/bad.py
+++ b/doc/data/messages/i/import-self/bad.py
@@ -1,5 +1,5 @@
-from bad import a_function # [import-self]
-
-
-def a_function():
- pass
+from bad import a_function # [import-self]
+
+
+def a_function():
+ pass
diff --git a/doc/data/messages/l/logging-format-interpolation/details.rst b/doc/data/messages/l/logging-format-interpolation/details.rst
index 7344b3f84..984484a06 100644
--- a/doc/data/messages/l/logging-format-interpolation/details.rst
+++ b/doc/data/messages/l/logging-format-interpolation/details.rst
@@ -1,2 +1,2 @@
-Another reasonable option is to use f-string. If you want to do that, you need to enable
+Another reasonable option is to use f-string. If you want to do that, you need to enable
``logging-format-interpolation`` and disable ``logging-fstring-interpolation``.
diff --git a/doc/data/messages/l/logging-fstring-interpolation/details.rst b/doc/data/messages/l/logging-fstring-interpolation/details.rst
index d29646061..c472f1d8b 100644
--- a/doc/data/messages/l/logging-fstring-interpolation/details.rst
+++ b/doc/data/messages/l/logging-fstring-interpolation/details.rst
@@ -1,2 +1,2 @@
-This message permits to allow f-string in logging and still be warned of
+This message permits to allow f-string in logging and still be warned of
``logging-format-interpolation``.
diff --git a/doc/data/messages/u/use-a-generator/details.rst b/doc/data/messages/u/use-a-generator/details.rst
index 3abe2d748..a2cd578e4 100644
--- a/doc/data/messages/u/use-a-generator/details.rst
+++ b/doc/data/messages/u/use-a-generator/details.rst
@@ -1,3 +1,3 @@
-By using a generator you can cut the execution tree and exit directly at the first element that is ``False`` for ``all`` or ``True`` for ``any`` instead of
-calculating all the elements. Except in the worst possible case where you still need to evaluate everything (all values
+By using a generator you can cut the execution tree and exit directly at the first element that is ``False`` for ``all`` or ``True`` for ``any`` instead of
+calculating all the elements. Except in the worst possible case where you still need to evaluate everything (all values
are True for ``all`` or all values are false for ``any``) performance will be better.
diff --git a/doc/data/messages/u/use-dict-literal/details.rst b/doc/data/messages/u/use-dict-literal/details.rst
index f07532ead..8511485cd 100644
--- a/doc/data/messages/u/use-dict-literal/details.rst
+++ b/doc/data/messages/u/use-dict-literal/details.rst
@@ -1,4 +1,4 @@
-https://gist.github.com/hofrob/ad143aaa84c096f42489c2520a3875f9
-
-This example script shows an 18% increase in performance when using a literal over the
-constructor in python version 3.10.6.
+https://gist.github.com/hofrob/ad143aaa84c096f42489c2520a3875f9
+
+This example script shows an 18% increase in performance when using a literal over the
+constructor in python version 3.10.6.
diff --git a/doc/data/messages/u/using-final-decorator-in-unsupported-version/bad.py b/doc/data/messages/u/using-final-decorator-in-unsupported-version/bad.py
index 59ec6ebc3..1cfcad6c4 100644
--- a/doc/data/messages/u/using-final-decorator-in-unsupported-version/bad.py
+++ b/doc/data/messages/u/using-final-decorator-in-unsupported-version/bad.py
@@ -1,8 +1,8 @@
-from typing import final
-
-
-@final # [using-final-decorator-in-unsupported-version]
-class Playtypus(Animal):
- @final # [using-final-decorator-in-unsupported-version]
- def lay_egg(self):
- ...
+from typing import final
+
+
+@final # [using-final-decorator-in-unsupported-version]
+class Playtypus(Animal):
+ @final # [using-final-decorator-in-unsupported-version]
+ def lay_egg(self):
+ ...
diff --git a/doc/data/messages/u/using-final-decorator-in-unsupported-version/good.py b/doc/data/messages/u/using-final-decorator-in-unsupported-version/good.py
index 9fe62f8f7..d2f76b4ce 100644
--- a/doc/data/messages/u/using-final-decorator-in-unsupported-version/good.py
+++ b/doc/data/messages/u/using-final-decorator-in-unsupported-version/good.py
@@ -1,3 +1,3 @@
-class Playtypus(Animal):
- def lay_egg(self):
- ...
+class Playtypus(Animal):
+ def lay_egg(self):
+ ...