summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/CONTRIBUTING.md2
-rw-r--r--README.rst18
-rw-r--r--doc/conf.py2
-rw-r--r--doc/development_guide/how_tos/custom_checkers.rst2
-rw-r--r--doc/whatsnew/2/2.9/summary.rst2
-rw-r--r--pylint/message/_deleted_message_ids.py4
-rw-r--r--pyproject.toml6
-rw-r--r--tests/functional/b/bad_option_value.txt12
8 files changed, 24 insertions, 24 deletions
diff --git a/.github/CONTRIBUTING.md b/.github/CONTRIBUTING.md
index 9231d293d..61adbec74 100644
--- a/.github/CONTRIBUTING.md
+++ b/.github/CONTRIBUTING.md
@@ -1,2 +1,2 @@
Please read the
-[contribute doc](https://pylint.pycqa.org/en/latest/development_guide/contributor_guide/contribute.html).
+[contribute doc](https://pylint.readthedocs.io/en/latest/development_guide/contributor_guide/contribute.html).
diff --git a/README.rst b/README.rst
index 09e75daee..ab902d995 100644
--- a/README.rst
+++ b/README.rst
@@ -1,7 +1,7 @@
`Pylint`_
=========
-.. _`Pylint`: https://pylint.pycqa.org/
+.. _`Pylint`: https://pylint.readthedocs.io/
.. This is used inside the doc to recover the start of the introduction
@@ -74,7 +74,7 @@ Or if you want to also check spelling with ``enchant`` (you might need to
It can also be integrated in most editors or IDEs. More information can be found
`in the documentation`_.
-.. _in the documentation: https://pylint.pycqa.org/en/latest/user_guide/installation/index.html
+.. _in the documentation: https://pylint.readthedocs.io/en/latest/user_guide/installation/index.html
.. This is used inside the doc to recover the end of the short text for installation
@@ -119,7 +119,7 @@ ecosystem of existing plugins for popular frameworks and third party libraries.
`pylint-sonarjson`_ are examples of such plugins. More information about plugins
and how to load them can be found at `plugins`_.
-.. _`plugins`: https://pylint.pycqa.org/en/latest/development_guide/how_tos/plugins.html#plugins
+.. _`plugins`: https://pylint.readthedocs.io/en/latest/development_guide/how_tos/plugins.html#plugins
.. _`pylint-pydantic`: https://pypi.org/project/pylint-pydantic
.. _`pylint-django`: https://github.com/PyCQA/pylint-django
.. _`pylint-sonarjson`: https://github.com/omegacen/pylint-sonarjson
@@ -154,8 +154,8 @@ Pylint ships with three additional tools:
- pyreverse_ (standalone tool that generates package and class diagrams.)
- symilar_ (duplicate code finder that is also integrated in pylint)
-.. _pyreverse: https://pylint.pycqa.org/en/latest/pyreverse.html
-.. _symilar: https://pylint.pycqa.org/en/latest/symilar.html
+.. _pyreverse: https://pylint.readthedocs.io/en/latest/pyreverse.html
+.. _symilar: https://pylint.readthedocs.io/en/latest/symilar.html
.. This is used inside the doc to recover the end of the introduction
@@ -172,9 +172,9 @@ you found a bug or want a feature`_, etc. Everything is much appreciated!
Please follow the `code of conduct`_ and check `the Contributor Guides`_ if you want to
make a code contribution.
-.. _creating issues because you found a bug or want a feature: https://pylint.pycqa.org/en/latest/contact.html#bug-reports-feedback
+.. _creating issues because you found a bug or want a feature: https://pylint.readthedocs.io/en/latest/contact.html#bug-reports-feedback
.. _code of conduct: https://github.com/PyCQA/pylint/blob/main/CODE_OF_CONDUCT.md
-.. _the Contributor Guides: https://pylint.pycqa.org/en/latest/development_guide/contribute.html
+.. _the Contributor Guides: https://pylint.readthedocs.io/en/latest/development_guide/contribute.html
.. This is used inside the doc to recover the end of the short text for contribution
@@ -188,7 +188,7 @@ You can place this badge in your README to let others know your project uses pyl
Learn how to add a badge to your documentation in the `the badge documentation`_.
-.. _the badge documentation: https://pylint.pycqa.org/en/latest/user_guide/installation/badge.html
+.. _the badge documentation: https://pylint.readthedocs.io/en/latest/user_guide/installation/badge.html
License
-------
@@ -205,7 +205,7 @@ Support
Please check `the contact information`_.
-.. _`the contact information`: https://pylint.pycqa.org/en/latest/contact.html
+.. _`the contact information`: https://pylint.readthedocs.io/en/latest/contact.html
.. |tideliftlogo| image:: https://raw.githubusercontent.com/PyCQA/pylint/main/doc/media/Tidelift_Logos_RGB_Tidelift_Shorthand_On-White.png
:width: 200
diff --git a/doc/conf.py b/doc/conf.py
index b65cdd8a0..76968ec36 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -288,7 +288,7 @@ man_pages = [
# pylint: disable-next=consider-using-namedtuple-or-dataclass
intersphinx_mapping = {
- "astroid": ("https://pylint.pycqa.org/projects/astroid/en/latest/", None),
+ "astroid": ("https://pylint.readthedocs.io/projects/astroid/en/latest/", None),
"python": ("https://docs.python.org/3", None),
}
diff --git a/doc/development_guide/how_tos/custom_checkers.rst b/doc/development_guide/how_tos/custom_checkers.rst
index 3cbf81c83..ab44f06bd 100644
--- a/doc/development_guide/how_tos/custom_checkers.rst
+++ b/doc/development_guide/how_tos/custom_checkers.rst
@@ -156,7 +156,7 @@ We could also construct a more complete example::
For ``astroid.extract_node``, you can use ``#@`` at the end of a line to choose which statements will be extracted into nodes.
For more information on ``astroid.extract_node``,
-see the `astroid documentation <https://pylint.pycqa.org/projects/astroid/en/latest/>`_.
+see the `astroid documentation <https://pylint.readthedocs.io/projects/astroid/en/latest/>`_.
Now we know how to use the astroid node, we can implement our check.
diff --git a/doc/whatsnew/2/2.9/summary.rst b/doc/whatsnew/2/2.9/summary.rst
index c3a7c5b5e..f5e137d5f 100644
--- a/doc/whatsnew/2/2.9/summary.rst
+++ b/doc/whatsnew/2/2.9/summary.rst
@@ -15,7 +15,7 @@ new checks optional is a step in that direction. In order to do that we
created an optional code style checker that can be loaded using
``pylint.extensions.code_style`` with the ``load-plugins`` options.
More than ever, if as a veteran you want the most checks you can possibly get,
-`you should check the list of pylint extensions. <https://pylint.pycqa.org/en/latest/user_guide/checkers/extensions.html#optional-checkers>`_.
+`you should check the list of pylint extensions. <https://pylint.readthedocs.io/en/latest/user_guide/checkers/extensions.html#optional-checkers>`_.
New checkers
diff --git a/pylint/message/_deleted_message_ids.py b/pylint/message/_deleted_message_ids.py
index 9415bafb0..4f361c96a 100644
--- a/pylint/message/_deleted_message_ids.py
+++ b/pylint/message/_deleted_message_ids.py
@@ -112,7 +112,7 @@ DELETED_MESSAGES_IDS = {
"https://github.com/PyCQA/pylint/pull/3571": [
DeletedMessage("C0330", "bad-continuation")
],
- "https://pylint.pycqa.org/en/latest/whatsnew/1/1.4.html#what-s-new-in-pylint-1-4-3": [
+ "https://pylint.readthedocs.io/en/latest/whatsnew/1/1.4.html#what-s-new-in-pylint-1-4-3": [
DeletedMessage("R0921", "abstract-class-not-used"),
DeletedMessage("R0922", "abstract-class-little-used"),
DeletedMessage("W0142", "star-args"),
@@ -125,7 +125,7 @@ DELETED_MESSAGES_IDS = {
],
}
MOVED_TO_EXTENSIONS = {
- "https://pylint.pycqa.org/en/latest/whatsnew/2/2.14/summary.html#removed-checkers": [
+ "https://pylint.readthedocs.io/en/latest/whatsnew/2/2.14/summary.html#removed-checkers": [
DeletedMessage("R0201", "no-self-use")
],
}
diff --git a/pyproject.toml b/pyproject.toml
index f184d9398..00a30c91f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -54,13 +54,13 @@ testutils = ["gitpython>3"]
spelling = ["pyenchant~=3.2"]
[project.urls]
-"Docs: User Guide" = "https://pylint.pycqa.org/en/latest/"
+"Docs: User Guide" = "https://pylint.readthedocs.io/en/latest/"
"Source Code" = "https://github.com/PyCQA/pylint"
"homepage" = "https://github.com/PyCQA/pylint"
-"What's New" = "https://pylint.pycqa.org/en/latest/whatsnew/2/"
+"What's New" = "https://pylint.readthedocs.io/en/latest/whatsnew/2/"
"Bug Tracker" = "https://github.com/PyCQA/pylint/issues"
"Discord Server" = "https://discord.com/invite/Egy6P8AMB5"
-"Docs: Contributor Guide" = "https://pylint.pycqa.org/en/latest/development_guide/contributor_guide/index.html"
+"Docs: Contributor Guide" = "https://pylint.readthedocs.io/en/latest/development_guide/contributor_guide/index.html"
[project.scripts]
pylint = "pylint:run_pylint"
diff --git a/tests/functional/b/bad_option_value.txt b/tests/functional/b/bad_option_value.txt
index 2647a2678..ce7605691 100644
--- a/tests/functional/b/bad_option_value.txt
+++ b/tests/functional/b/bad_option_value.txt
@@ -1,17 +1,17 @@
unknown-option-value:4:0:None:None::Unknown option value for 'disable', expected a valid pylint message and got 'C05048':HIGH
useless-option-value:6:0:None:None::"Useless option value for 'disable', 'execfile-builtin' was removed from pylint, see https://github.com/PyCQA/pylint/pull/4942.":HIGH
-useless-option-value:8:0:None:None::"Useless option value for 'disable', 'no-self-use' was moved to an optional extension, see https://pylint.pycqa.org/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
+useless-option-value:8:0:None:None::"Useless option value for 'disable', 'no-self-use' was moved to an optional extension, see https://pylint.readthedocs.io/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
useless-option-value:10:0:None:None::"Useless option value for 'disable', 'W1656' was removed from pylint, see https://github.com/PyCQA/pylint/pull/4942.":HIGH
-useless-option-value:12:0:None:None::"Useless option value for 'disable', 'R0201' was moved to an optional extension, see https://pylint.pycqa.org/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
+useless-option-value:12:0:None:None::"Useless option value for 'disable', 'R0201' was moved to an optional extension, see https://pylint.readthedocs.io/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
unknown-option-value:14:0:None:None::Unknown option value for 'disable-next', expected a valid pylint message and got 'R78948':HIGH
useless-option-value:16:0:None:None::"Useless option value for 'disable-next', 'deprecated-types-field' was removed from pylint, see https://github.com/PyCQA/pylint/pull/4942.":HIGH
useless-option-value:18:0:None:None::"Useless option value for 'disable-next', 'W1634' was removed from pylint, see https://github.com/PyCQA/pylint/pull/4942.":HIGH
-useless-option-value:20:0:None:None::"Useless option value for 'disable-next', 'no-self-use' was moved to an optional extension, see https://pylint.pycqa.org/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
-useless-option-value:22:0:None:None::"Useless option value for 'disable-next', 'R0201' was moved to an optional extension, see https://pylint.pycqa.org/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
+useless-option-value:20:0:None:None::"Useless option value for 'disable-next', 'no-self-use' was moved to an optional extension, see https://pylint.readthedocs.io/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
+useless-option-value:22:0:None:None::"Useless option value for 'disable-next', 'R0201' was moved to an optional extension, see https://pylint.readthedocs.io/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
unknown-option-value:25:0:None:None::Unknown option value for 'enable', expected a valid pylint message and got 'W04044':HIGH
useless-option-value:27:0:None:None::"Useless option value for 'enable', 'dict-values-not-iterating' was removed from pylint, see https://github.com/PyCQA/pylint/pull/4942.":HIGH
-useless-option-value:29:0:None:None::"Useless option value for 'enable', 'no-self-use' was moved to an optional extension, see https://pylint.pycqa.org/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
+useless-option-value:29:0:None:None::"Useless option value for 'enable', 'no-self-use' was moved to an optional extension, see https://pylint.readthedocs.io/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
useless-option-value:31:0:None:None::"Useless option value for 'enable', 'W1622' was removed from pylint, see https://github.com/PyCQA/pylint/pull/4942.":HIGH
-useless-option-value:33:0:None:None::"Useless option value for 'enable', 'R0201' was moved to an optional extension, see https://pylint.pycqa.org/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
+useless-option-value:33:0:None:None::"Useless option value for 'enable', 'R0201' was moved to an optional extension, see https://pylint.readthedocs.io/en/latest/whatsnew/2/2.14/summary.html#removed-checkers.":HIGH
useless-option-value:36:0:None:None::"Useless option value for 'disable', 'no-space-after-operator' was removed from pylint, see https://github.com/PyCQA/pylint/pull/3577.":HIGH
useless-option-value:38:0:None:None::"Useless option value for 'disable', 'C0323' was removed from pylint, see https://github.com/PyCQA/pylint/pull/3577.":HIGH