summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--doc/whatsnew/fragments/5488.other3
-rw-r--r--pylint/py.typed0
-rw-r--r--pyproject.toml3
3 files changed, 5 insertions, 1 deletions
diff --git a/doc/whatsnew/fragments/5488.other b/doc/whatsnew/fragments/5488.other
new file mode 100644
index 000000000..0f6ac5b85
--- /dev/null
+++ b/doc/whatsnew/fragments/5488.other
@@ -0,0 +1,3 @@
+Pylint now exposes its type annotations.
+
+Closes #5488 and #2079
diff --git a/pylint/py.typed b/pylint/py.typed
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/pylint/py.typed
diff --git a/pyproject.toml b/pyproject.toml
index 0c2b2a817..e5ab0d735 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -30,6 +30,7 @@ classifiers = [
"Topic :: Software Development :: Debuggers",
"Topic :: Software Development :: Quality Assurance",
"Topic :: Software Development :: Testing",
+ "Typing :: Typed"
]
requires-python = ">=3.7.2"
dependencies = [
@@ -75,7 +76,7 @@ license-files = ["LICENSE", "CONTRIBUTORS.txt"] # Keep in sync with setup.cfg
include = ["pylint*"]
[tool.setuptools.package-data]
-pylint = ["testutils/testing_pylintrc"]
+pylint = ["testutils/testing_pylintrc", "py.typed"]
[tool.setuptools.dynamic]
version = {attr = "pylint.__pkginfo__.__version__"}