summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.pre-commit-config.yaml14
1 files changed, 14 insertions, 0 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index b13f5112d..15d6a71d2 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -132,3 +132,17 @@ repos:
exclude: *fixtures
args: ["--max-summary-lines=2", "--linewrap-full-docstring"]
files: "pylint"
+ - repo: https://github.com/regebro/pyroma
+ rev: "4.1"
+ hooks:
+ - id: pyroma
+ # Must be specified because of the default value in pyroma
+ always_run: false
+ files: |
+ (?x)^(
+ README.rst|
+ pyproject.toml|
+ pylint/__init__.py|
+ pylint/__pkginfo__.py|
+ setup.cfg
+ )$