summaryrefslogtreecommitdiff
path: root/examples/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'examples/pyproject.toml')
-rw-r--r--examples/pyproject.toml16
1 files changed, 12 insertions, 4 deletions
diff --git a/examples/pyproject.toml b/examples/pyproject.toml
index 061ddaf22..b419f83e7 100644
--- a/examples/pyproject.toml
+++ b/examples/pyproject.toml
@@ -34,12 +34,15 @@ fail-under = 10
# Files or directories to be skipped. They should be base names, not paths.
ignore = ["CVS"]
-# Add files or directories matching the regex patterns to the ignore-list. The
-# regex matches against paths and can be in Posix or Windows format.
+# Add files or directories matching the regular expressions patterns to the
+# ignore-list. The regex matches against paths and can be in Posix or Windows
+# format. Because '\' represents the directory delimiter on Windows systems, it
+# can't be used as an escape character.
# ignore-paths =
-# Files or directories matching the regex patterns are skipped. The regex matches
-# against base names, not paths. The default value ignores Emacs file locks
+# Files or directories matching the regular expression patterns are skipped. The
+# regex matches against base names, not paths. The default value ignores Emacs
+# file locks
ignore-patterns = ["^\\.#"]
# List of module names for which member attributes should not be checked (useful
@@ -353,6 +356,11 @@ disable = ["raw-checker-failed", "bad-inline-option", "locally-disabled", "file-
# should appear only once). See also the "--disable" option for examples.
enable = ["c-extension-no-member"]
+[tool.pylint.method_args]
+# List of qualified names (i.e., library.method) which require a timeout
+# parameter e.g. 'requests.api.get,requests.api.post'
+timeout-methods = ["requests.api.delete", "requests.api.get", "requests.api.head", "requests.api.options", "requests.api.patch", "requests.api.post", "requests.api.put", "requests.api.request"]
+
[tool.pylint.miscellaneous]
# List of note tags to take in consideration, separated by a comma.
notes = ["FIXME", "XXX", "TODO"]