summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 6 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 80547df05..1c8a915ac 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -130,10 +130,13 @@ module = [
"pytest",
"sphinx.*",
]
+
[tool.ruff]
-select = ["E", "F", "B"]
+select = ["E", "F", "W", "B"]
ignore = [
"B905", # Not enforced previousely
]
-fixable = ["E", "F", "B"]
-line-length = 125
+fixable = ["E", "F", "W", "B"]
+# ruff is less lenient than pylint and does not make any exceptions
+# (for docstrings, strings and comments in particular).
+line-length = 115