summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml26
1 files changed, 21 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e5ab0d735..238b1fcb0 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -132,11 +132,27 @@ module = [
]
[tool.ruff]
-select = ["E", "F", "W", "B"]
-ignore = [
- "B905", # Not enforced previousely
-]
-fixable = ["E", "F", "W", "B"]
+
# ruff is less lenient than pylint and does not make any exceptions
# (for docstrings, strings and comments in particular).
line-length = 115
+
+select = [
+ "E", # pycodestyle
+ "F", # pyflakes
+ "W", # pycodestyle
+ "B", # bugbear
+ "I", # isort
+]
+
+ignore = [
+ "B905", # `zip()` without an explicit `strict=` parameter
+]
+
+fixable = [
+ "E", # pycodestyle
+ "F", # pyflakes
+ "W", # pycodestyle
+ "B", # bugbear
+ "I", # isort
+]