summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg7
1 files changed, 3 insertions, 4 deletions
diff --git a/setup.cfg b/setup.cfg
index b6ebd2b77..e4c696c4c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -12,15 +12,14 @@ license_files =
# Incompatible with black see https://github.com/ambv/black/issues/315
# E203: Whitespace before ':'
# W503: Line break occurred before a binary operator
-# E501: Line too long
# B028: consider using the `!r` conversion flag
ignore =
E203,
W503,
- E501,
B028,
-max-line-length=88
-max-complexity=39
+# Flake8 is less lenient than pylint and does not make any exceptions
+# (for docstrings, strings and comments in particular).
+max-line-length=125
# Required for flake8-typing-imports (v1.12.0)
# The plugin doesn't yet read the value from pyproject.toml
min_python_version = 3.7.2