summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClaudiu Popa <pcmanticore@gmail.com>2015-11-29 18:37:40 +0200
committerClaudiu Popa <pcmanticore@gmail.com>2015-11-29 18:37:40 +0200
commit95dfa2f08056d30efa1dbc8aff1ecf6fabe3707b (patch)
tree858c1d20c0724b12295e1e064c29633a999538fd
parent5bfb27f82aebc1624ca6c1ca2894b80032cb2c14 (diff)
downloadpylint-1.5.tar.gz
Drop any reference for logilab-common from the documentation. Update the contribution section for newer practices regarding testing.pylint-1.5
-rw-r--r--DEPENDS3
-rw-r--r--doc/contribute.rst34
-rw-r--r--doc/faq.rst3
-rw-r--r--doc/installation.rst5
4 files changed, 11 insertions, 34 deletions
diff --git a/DEPENDS b/DEPENDS
index 653dfcb..50c8ae7 100644
--- a/DEPENDS
+++ b/DEPENDS
@@ -1,3 +1,2 @@
-python-logilab-common (>= 0.19.0)
-python-astroid (>= 1.3.6)
+python-astroid (>= 1.4.0)
python-tk
diff --git a/doc/contribute.rst b/doc/contribute.rst
index 43e5dfb..5cd5026 100644
--- a/doc/contribute.rst
+++ b/doc/contribute.rst
@@ -22,10 +22,9 @@ python code.
Note that if you don't find something you have expected in Pylint's
issue tracker, it may be because it is an issue with one of its dependencies, namely
-astroid and logilab-common:
+astroid.
* https://bitbucket.org/logilab/astroid
-* http://www.logilab.org/project/logilab-common
Mailing lists
-------------
@@ -89,32 +88,13 @@ your patch gets accepted.
Unit test setup
---------------
-To run the pylint unit tests within your checkout (without having to install
-anything), you need to set PYTHONPATH so that pylint, astroid and the
-logilab-common are available. Assume you have those packages in ~/src. If
-you have a normal clone of logilab-common, it will not be properly
-structured to allow import of logilab.common. To remedy this, create the
-necessary structure::
+If you have tox installed, running ``tox`` command should be
+enough to get you started. Otherwise, you can follow this recipe
+for running the tests for pylint::
- cd ~/src
- mkdir logilab
- mv logilab-common logilab/common
- touch logilab/__init__.py
-
-Now, set PYTHONPATH to your src directory::
-
- export PYTHONPATH=~/src
-
-You now have access to the astroid, logilab.common and pylint packages
-without installing them. You can run all the unit tests like so::
-
- cd ~/src/pylint/test
- for f in *.py ; do
- echo $f
- python -S $f
- done
-
-The -S flag keeps distutils from interfering with sys.path. YMMV.
+ python setup.py develop # or ``pip install -e .``
+ cd pylint/test
+ python -m unittest discover -p "*test*"
Adding new functional tests
diff --git a/doc/faq.rst b/doc/faq.rst
index 2f7dfbb..3002bdd 100644
--- a/doc/faq.rst
+++ b/doc/faq.rst
@@ -66,11 +66,10 @@ Pylint from the repository, simply invoke ::
2.3 What are Pylint's dependencies?
-----------------------------------
-Pylint requires the latest `astroid`_ and `logilab-common`_ packages. It should be
+Pylint requires the latest `astroid`_. It should be
compatible with any Python version greater than 2.7.0.
.. _`astroid`: https://bitbucket.org/logilab/astroid
-.. _`logilab-common`: http://www.logilab.org/project/logilab-common
2.4 What versions of Python is Pylint supporting?
--------------------------------------------------
diff --git a/doc/installation.rst b/doc/installation.rst
index eca0fa3..ec21ccf 100644
--- a/doc/installation.rst
+++ b/doc/installation.rst
@@ -4,11 +4,10 @@ Installation
Dependencies
''''''''''''
-Pylint requires the latest `astroid`_ and `logilab-common`_
-packages. It should be compatible with any Python version >= 2.7.
+Pylint requires the latest `astroid`_ package.
+It should be compatible with any Python version >= 2.7.
.. _`astroid`: https://bitbucket.org/logilab/astroid
-.. _`logilab-common`: http://www.logilab.org/project/logilab-common
Distributions