summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:04:54 +0200
committerMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:04:54 +0200
commit965366e716cdc247a9918df8c542857342fe9827 (patch)
tree38e621401fd18931c0f7f649b3581dd9a392c186 /Makefile
parent9f853759f14569f6069497036c5c7e9c7c88d5d2 (diff)
downloadpylint-965366e716cdc247a9918df8c542857342fe9827.tar.gz
Fixed generating docs from Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 1fc985d..83fb5b8 100644
--- a/Makefile
+++ b/Makefile
@@ -27,10 +27,11 @@ endif
tests: $(TOX)
$(TOX) $(toxparams)
-docs:
+docs: $(PIP)
rm -f /tmp/pylint
ln -s -f $(CURDIR) /tmp/pylint
- PYTHONPATH=/tmp make all -C doc
+ $(PIP) install .
+ PYTHONPATH=/tmp PATH=$(CURDIR)/pyve/bin:$(PATH) make all -C doc
deb:
debuild -b -us -uc
@@ -42,6 +43,7 @@ lint: $(PIP)
clean:
rm -rf $(PYVE)
rm -rf .tox
+ rm -rf /tmp/pylint1 /tmp/pylint2
make clean -C doc
debuild clean