summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:49:54 +0200
committerMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:49:54 +0200
commitb43aa5c9064351f70d495b85289a278fe5fca4ac (patch)
tree4b83cdaaf3c6b12f78e5f7dbdf0a1f5c3c3a076f /Makefile
parent2f5a62c248ebef8e701ae7cebe59be20b28c720e (diff)
downloadpylint-b43aa5c9064351f70d495b85289a278fe5fca4ac.tar.gz
Improved building packages.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile28
1 files changed, 22 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index a4571b8..5002ea1 100644
--- a/Makefile
+++ b/Makefile
@@ -3,6 +3,11 @@ PYVE=pyve
PIP=$(PYVE)/bin/pip
TOX=$(PYVE)/bin/tox
+VERSION=$(shell PYTHONPATH=. python -c "from __pkginfo__ import version; print version")
+
+PKG_SDIST=dist/pylint-$(VERSION).tar.gz
+PKG_DEB=../pylint_$(VERSION)-1_all.deb
+
# this is default target, it should always be first in this Makefile
help:
@echo "Please use \`make <target>' where <target> is one of"
@@ -32,19 +37,30 @@ docs: $(PIP)
$(PIP) install Sphinx
. $(PYVE)/bin/activate; make all -C doc
-deb:
+deb: $(PKG_DEB)
+$(PKG_DEB): /usr/bin/debuild
debuild -b -us -uc
+sdist: $(PKG_SDIST)
+$(PKG_SDIST):
+ python setup.py sdist
+
lint: $(PIP)
$(PIP) install .
- $(PYVE)/bin/pylint lint.py
+ $(PYVE)/bin/pylint lint.py || true # for now ignore errors
-clean:
+clean: /usr/bin/debuild
rm -rf $(PYVE)
rm -rf .tox
+ rm -rf dist
+ rm -rf build
make clean -C doc
- #debuild clean
+ debuild clean
+ rm -rf $(PKG_DEB)
+
+/usr/bin/debuild:
+ sudo apt-get -y --force-yes install devscripts
-all: clean lint tests docs deb
+all: clean lint tests docs sdist deb
-.PHONY: help tests docs deb lint clean all
+.PHONY: help tests docs deb sdist lint clean all