summaryrefslogtreecommitdiff
path: root/README.Python3
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2011-12-05 14:10:29 +0100
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2011-12-05 14:10:29 +0100
commit17c5d6905a96f9e938673e2f030b0a8433c7f00a (patch)
tree75726248229735ab20dde1eb86497456dde96722 /README.Python3
parent8dcf87cbc25e0d58c2ef669663f03d7dafd31228 (diff)
downloadpylint-17c5d6905a96f9e938673e2f030b0a8433c7f00a.tar.gz
[doc] update README.Python3 (closes: #82421)
Forget hardy distribution.
Diffstat (limited to 'README.Python3')
-rw-r--r--README.Python331
1 files changed, 18 insertions, 13 deletions
diff --git a/README.Python3 b/README.Python3
index 3c94863..ccc9297 100644
--- a/README.Python3
+++ b/README.Python3
@@ -1,26 +1,27 @@
Python3
=======
-Source
-------
+Compatibility
+-------------
+
+Please, consider python3 >= 3.2 only.
-Python3 portage is made by running the 2to3 script on all modules::
- find . ! -path "*/test/*py" -name "*py" -exec 2to3-3.1 -wn {} \;
+Approach
+--------
+We maintain a Python 2 base and use 2to3 to generate Python 3 code.
-Dev
----
+2to3 is integrated into the distutils installation process and will be run as a
+build step when invoked by the python3 interpreter::
-If you want to run the tests, simply remove the "! -path ..." option, hence
-also refactoring the test files, including all data files.
-Note that when running 2to3 on some test/input/ files, it will crash since
-this folder contains corrupted files. Hence, we can not run directly
-*2to3* on the test folder::
+ NO_SETUPTOOLS=1 python3 setup.py install --no-compile
- $ 2to3 test/
+In order to run pylint locally, you have to install the dependencies::
+
+ easy_install-3.2 logilab-common
+ easy_install-3.2 logilab-astng
-But it will work nice with *find*.
Debian
------
@@ -30,3 +31,7 @@ the debian/ folder::
cp debian.py3k/* debian/
+
+Resources
+---------
+http://wiki.python.org/moin/PortingPythonToPy3k