summaryrefslogtreecommitdiff
path: root/README.Python3
diff options
context:
space:
mode:
authorBrett Cannon <brett@python.org>2014-10-31 12:04:10 -0400
committerBrett Cannon <brett@python.org>2014-10-31 12:04:10 -0400
commit2baad676aba7e4a47cc1f66c1b5a66b85a4af873 (patch)
treee49eeddffbfe34869d50a6d40d2ed94233e0e440 /README.Python3
parenta4e9abc125741b4b3d61f8e16d90c402ea6cd002 (diff)
downloadpylint-2baad676aba7e4a47cc1f66c1b5a66b85a4af873.tar.gz
Update Python 3 README
Diffstat (limited to 'README.Python3')
-rw-r--r--README.Python310
1 files changed, 3 insertions, 7 deletions
diff --git a/README.Python3 b/README.Python3
index aee0f2b..897e946 100644
--- a/README.Python3
+++ b/README.Python3
@@ -10,17 +10,13 @@ Please, consider python3 >= 3.2 only.
Approach
--------
-We maintain a Python 2 base and use 2to3 to generate Python 3 code.
-
-2to3 is integrated into the distutils installation process and will be run as a
-build step when invoked by the python3 interpreter::
-
- NO_SETUPTOOLS=1 python3 setup.py install --no-compile
+We maintain a code base that is Python 2/3 compatible simultaneously.
In order to run pylint locally, you have to install the dependencies::
easy_install-3.2 logilab-common
easy_install-3.2 astroid
+ easy_install-3.2 six
Debian
@@ -34,4 +30,4 @@ the debian/ folder::
Resources
---------
-http://wiki.python.org/moin/PortingPythonToPy3k
+https://docs.python.org/3/howto/pyporting.html