summaryrefslogtreecommitdiff
path: root/debian.sid
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2011-12-05 14:10:29 +0100
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2011-12-05 14:10:29 +0100
commit17c5d6905a96f9e938673e2f030b0a8433c7f00a (patch)
tree75726248229735ab20dde1eb86497456dde96722 /debian.sid
parent8dcf87cbc25e0d58c2ef669663f03d7dafd31228 (diff)
downloadpylint-17c5d6905a96f9e938673e2f030b0a8433c7f00a.tar.gz
[doc] update README.Python3 (closes: #82421)
Forget hardy distribution.
Diffstat (limited to 'debian.sid')
-rw-r--r--debian.sid/control61
-rwxr-xr-xdebian.sid/rules56
-rw-r--r--debian.sid/source/format1
3 files changed, 118 insertions, 0 deletions
diff --git a/debian.sid/control b/debian.sid/control
new file mode 100644
index 0000000..8941f09
--- /dev/null
+++ b/debian.sid/control
@@ -0,0 +1,61 @@
+Source: pylint
+Section: python
+Priority: optional
+Maintainer: Logilab S.A. <contact@logilab.fr>
+Uploaders: Sylvain Thénault <sylvain.thenault@logilab.fr>, Alexandre Fayolle <afayolle@debian.org>,
+ Sandro Tosi <morph@debian.org>, Julien Jehannet <julien.jehannet@logilab.fr>
+Build-Depends: debhelper (>= 7.0.50~), python-all, python3-all
+Standards-Version: 3.9.2
+Homepage: http://www.logilab.org/project/pylint
+Vcs-Hg: http://hg.logilab.org/pylint
+Vcs-Browser: http://hg.logilab.org/pylint
+
+Package: pylint
+Architecture: all
+Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.53), python-logilab-astng (>= 0.21)
+Recommends: python-tk
+XB-Python-Version: ${python:Versions}
+Description: python code static checker and UML diagram generator
+ Pylint is a Python source code analyzer which looks for programming
+ errors, helps enforcing a coding standard and sniffs for some code
+ smells (as defined in Martin Fowler's Refactoring book)
+ .
+ Pylint can be seen as another PyChecker since nearly all tests you
+ can do with PyChecker can also be done with Pylint. However, Pylint
+ offers some more features, like checking length of lines of code,
+ checking if variable names are well-formed according to your coding
+ standard, or checking if declared interfaces are truly implemented,
+ and much more.
+ .
+ Additionally, it is possible to write plugins to add your own checks.
+ .
+ The included command pyreverse generates UML class and package
+ diagrams.
+ .
+ The recommended python-tk package is only for using the pylint-gui
+ script.
+
+Package: pylint3
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}, python3-logilab-common (>= 0.53), python3-logilab-astng (>= 0.21)
+Recommends: python3-tk
+XB-Python-Version: ${python3:Versions}
+Description: python code static checker and UML diagram generator
+ Pylint is a Python source code analyzer which looks for programming
+ errors, helps enforcing a coding standard and sniffs for some code
+ smells (as defined in Martin Fowler's Refactoring book)
+ .
+ Pylint can be seen as another PyChecker since nearly all tests you
+ can do with PyChecker can also be done with Pylint. However, Pylint
+ offers some more features, like checking length of lines of code,
+ checking if variable names are well-formed according to your coding
+ standard, or checking if declared interfaces are truly implemented,
+ and much more.
+ .
+ Additionally, it is possible to write plugins to add your own checks.
+ .
+ The included command pyreverse generates UML class and package
+ diagrams.
+ .
+ The recommended python-tk package is only for using the pylint-gui
+ script.
diff --git a/debian.sid/rules b/debian.sid/rules
new file mode 100755
index 0000000..6a0d59c
--- /dev/null
+++ b/debian.sid/rules
@@ -0,0 +1,56 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+#
+# adapted by Logilab for automatic generation by debianize
+# (part of the devtools project, http://www.logilab.org/projects/devtools)
+#
+# Copyright (c) 2003-2010 LOGILAB S.A. (Paris, FRANCE).
+# http://www.logilab.fr/ -- mailto:contact@logilab.fr
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+include /usr/share/python/python.mk
+
+PYLIB:=$(call py_libdir,$(shell pyversions -d))
+PACKAGE:=$(call py_pkgname,pylint,python)
+PYLIB3:=$(call py_libdir,python3.)
+PACKAGE3:="pylint3"
+
+%:
+ dh $@ --with python2,python3
+
+override_dh_install:
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/$(PACKAGE)/ \
+ ${py_setup_install_args}
+ NO_SETUPTOOLS=1 python3 setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/$(PACKAGE3)/ \
+ ${py_setup_install_args}
+ # rename executables
+ for executable in pylint pylint-gui symilar epylint pyreverse ; do \
+ new_exec="$$executable"3; \
+ mv $(CURDIR)/debian/$(PACKAGE3)/usr/bin/$$executable $(CURDIR)/debian/$(PACKAGE3)/usr/bin/$$new_exec; \
+ done
+
+ # remove test directory
+ rm -rf debian/*/usr/lib/python*/*-packages/pylint/test
+
+ # generate pylint man page automatically
+ #PYTHONPATH=$(CURDIR)/debian/$(PACKAGE)/$(PYLIB) python $(CURDIR)/bin/pylint --generate-man > $(CURDIR)/man/pylint.1
+
+ # rename and install man pages
+ dh_installman -ppylint man/*.1
+ cd man && for i in *.1; do cp -v $$i "$$(basename $$i .1)3.1"; done
+ dh_installman -ppylint3 man/*3.1
+
+override_dh_installdocs:
+ dh_installdocs README*
+ dh_installchangelogs -i ChangeLog
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ # PYTHON 2.X
+ # PYTHON 3.2
+endif
diff --git a/debian.sid/source/format b/debian.sid/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian.sid/source/format
@@ -0,0 +1 @@
+3.0 (quilt)