summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAlexandre Fayolle <alexandre.fayolle@logilab.fr>2006-06-15 10:44:22 +0200
committerAlexandre Fayolle <alexandre.fayolle@logilab.fr>2006-06-15 10:44:22 +0200
commit6ecb36bb64b2f301484a922a53fb298373637fec (patch)
tree27b8e148fb399f54cd8bdbfe1ccbce5aa595ad99 /debian
parentd38aa3a8e1cae2a9ca5cd0334bd03ae4e099fa29 (diff)
downloadpylint-6ecb36bb64b2f301484a922a53fb298373637fec.tar.gz
new python policy
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/control7
-rw-r--r--debian/pylint.dirs6
-rw-r--r--debian/pylint.postinst18
-rw-r--r--debian/pylint.prerm8
-rw-r--r--debian/rules19
6 files changed, 13 insertions, 48 deletions
diff --git a/debian/changelog b/debian/changelog
index a17751e..ae0be82 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,8 +2,9 @@ pylint (0.11.0-2) unstable; urgency=low
* Updated standards to 3.7.2
* use debhelper 5
+ * new python policy
- -- Alexandre Fayolle <afayolle@debian.org> Mon, 22 May 2006 12:13:07 +0200
+ -- Alexandre Fayolle <afayolle@debian.org> Thu, 15 Jun 2006 10:38:32 +0200
pylint (0.11.0-1) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 830c261..a149d65 100644
--- a/debian/control
+++ b/debian/control
@@ -3,13 +3,14 @@ Section: python
Priority: optional
Maintainer: Sylvain Thénault <sylvain.thenault@logilab.fr>
Uploaders: Alexandre Fayolle <afayolle@debian.org>
-Build-Depends: debhelper (>= 5.0.0), python-dev
+Build-Depends: debhelper (>= 5.0.37.1), python (>=2.3.5-7), python-dev (>=2.3.5-7), python-central
Standards-Version: 3.7.2
+XS-Python-Version: current
Package: pylint
Architecture: all
-Depends: python, python-logilab-common (>= 0.13.0), python-logilab-astng (>= 0.16.0), python-tk, emacsen-common
-Provides: python2.2-pylint, python2.3-pylint, python2.4-pylint, pylint-common, pylint-test
+Depends: ${python:Depends}, python-logilab-common (>= 0.13.0), python-logilab-astng (>= 0.16.0), python-tk, emacsen-common
+XB-Python-Version: ${python:Versions}
Conflicts: python2.2-pylint, python2.3-pylint, python2.4-pylint, pylint-common, pylint-test
Replaces: python2.2-pylint, python2.3-pylint, python2.4-pylint, pylint-common, pylint-test
Description: python code static checker
diff --git a/debian/pylint.dirs b/debian/pylint.dirs
index 3b56eda..6f8eb7a 100644
--- a/debian/pylint.dirs
+++ b/debian/pylint.dirs
@@ -1,7 +1 @@
-usr/lib/site-python
-usr/lib/site-python/pylint
-usr/share/doc/pylint
-usr/share/emacs/site-lisp/
-usr/share/emacs/site-lisp/pylint
-usr/share/doc/pylint
usr/share/doc/pylint/test
diff --git a/debian/pylint.postinst b/debian/pylint.postinst
index aa64362..c426afd 100644
--- a/debian/pylint.postinst
+++ b/debian/pylint.postinst
@@ -1,24 +1,6 @@
#! /bin/sh -e
#
-
-
-# precompile python files
-VERSION=2.3
-PACKAGEDIR=/usr/lib/site-python/pylint
-case "$1" in
- configure|abort-upgrade|abort-remove|abort-deconfigure)
- python$VERSION -O /usr/lib/python$VERSION/compileall.py -q $PACKAGEDIR
- python$VERSION /usr/lib/python$VERSION/compileall.py -q $PACKAGEDIR
- ;;
-
- *)
- echo "postinst called with unknown argument \`$1'" >&2
- exit 1
- ;;
-esac
-
-
#DEBHELPER#
exit 0
diff --git a/debian/pylint.prerm b/debian/pylint.prerm
index dbe2144..c426afd 100644
--- a/debian/pylint.prerm
+++ b/debian/pylint.prerm
@@ -1,14 +1,6 @@
#! /bin/sh -e
#
-# remove .pyc and .pyo files
-dpkg --listfiles pylint |
- awk '$0~/\.py$/ {print $0"c\n" $0"o"}' |
- xargs rm -f >&2
-
-
-
-
#DEBHELPER#
exit 0
diff --git a/debian/rules b/debian/rules
index f6a130d..c845b7b 100644
--- a/debian/rules
+++ b/debian/rules
@@ -11,11 +11,6 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-# This is the debhelper compatability version to use.
-export DH_COMPAT=5
-
-
-
build: build-stamp
build-stamp:
dh_testdir
@@ -36,11 +31,9 @@ install: build
dh_testroot
dh_clean -k
dh_installdirs
- python setup.py -q install_lib --no-compile --install-dir=debian/pylint/usr/lib/site-python
- python setup.py -q install_headers --install-dir=debian/pylint/usr/include/
- python setup.py -q install_scripts --install-dir=debian/pylint/usr/bin/
- # remove test directory (installed in a separated package)
- rm -rf debian/pylint/usr/lib/site-python/pylint/test
+ python setup.py -q install --no-compile --prefix=debian/pylint/usr/
+
+ rm -rf debian/pylint/usr/lib/python*/site-packages/pylint/test
if head -1 debian/pylint/usr/bin/pylint | grep "^#! */usr/bin" | grep "python" >/dev/null ; then \
sed -i "s@^#! */usr/bin/env \+python\$$@#!/usr/bin/python@" debian/pylint/usr/bin/pylint; \
fi
@@ -63,6 +56,8 @@ binary-indep: build install
dh_testdir
dh_testroot
dh_install -i
+ dh_pycentral -i
+ dh_python -i
gzip -9 -c ChangeLog > changelog.gz
dh_installchangelogs -i
dh_installexamples -i
@@ -77,8 +72,8 @@ binary-indep: build install
dh_md5sums -i
dh_builddeb -i
-
+binary-arch:
binary: binary-indep
-.PHONY: build clean binary binary-indep
+.PHONY: build clean binary binary-indep binary-arch