summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRicardo Gemignani <ricardo.gemignani@gmail.com>2014-03-06 03:08:25 -0300
committerRicardo Gemignani <ricardo.gemignani@gmail.com>2014-03-06 03:08:25 -0300
commit554f49e7d75d1cbbee7567c577744222295eadd4 (patch)
treea2369910dd3141431fefd3b05ad2138ebfa6e789 /setup.py
parent8240a55ab1ccab81925197e0a196fcfd6eac5e2b (diff)
downloadpylint-554f49e7d75d1cbbee7567c577744222295eadd4.tar.gz
except as replaced by commas, one with_statement future import added and StringFormat used to replace string.format when python < 2.6
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 745462a..9820c47 100644
--- a/setup.py
+++ b/setup.py
@@ -131,7 +131,12 @@ class MyInstallLib(install_lib.install_lib):
else:
exclude = set()
shutil.rmtree(dest, ignore_errors=True)
- shutil.copytree(directory, dest, ignore=lambda dir, names: list(set(names) & exclude))
+ shutil.copytree(directory, dest)
+ for (dirpath, dirnames, filenames) in os.walk(dest):
+ for n in filenames:
+ if n in exclude:
+ os.remove(os.path.join(dirpath, n))
+
if sys.version_info >= (3, 0):
# process manually python file in include_dirs (test data)