summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorsylvain thenault <sylvain.thenault@logilab.fr>2009-01-28 12:18:34 +0100
committersylvain thenault <sylvain.thenault@logilab.fr>2009-01-28 12:18:34 +0100
commit594086ea791293aefc4d64a3b98c4d101b8f8fc4 (patch)
tree192d24fbdb8bf478cfd7f34986841b39b1989aeb /setup.py
parente6f70414f543230a9b1fd6c715b147550d0bef6b (diff)
downloadpylint-594086ea791293aefc4d64a3b98c4d101b8f8fc4.tar.gz
setup.py fix
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 49268b6..85424f6 100644
--- a/setup.py
+++ b/setup.py
@@ -175,6 +175,8 @@ def install(**kwargs):
packages = [modname] + get_packages(os.getcwd(), modname)
if USE_SETUPTOOLS and install_requires:
kwargs['install_requires'] = install_requires
+ if USE_SETUPTOOLS and '--force-manifest' in sys.argv:
+ sys.argv.remove('--force-manifest')
kwargs['packages'] = packages
return setup(name = distname,
version = version,