summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFELD Boris <lothiraldan@gmail.com>2012-07-26 10:37:55 +0100
committerFELD Boris <lothiraldan@gmail.com>2012-07-26 10:37:55 +0100
commit78f5d8a1ec8b1fc7d96806faa12eb1d550e73628 (patch)
tree479b625ed1631df6465eb75f93cc36f203c1b06b /setup.py
parent1e1a1e8f5851093da41f6d35896e7644f73ed936 (diff)
downloadpylint-78f5d8a1ec8b1fc7d96806faa12eb1d550e73628.tar.gz
Do not include tests files for installation in setup.py. Clean setup.py for python3. Closes #72022. Closes #82417. Closes #76910.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 1 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index a764d2e..33854b5 100644
--- a/setup.py
+++ b/setup.py
@@ -38,9 +38,6 @@ except ImportError:
from distutils.command import install_lib
USE_SETUPTOOLS = 0
-# pylint needs to filter some test files expected to be wrong
-P3K_FILES_TO_IGNORE= ('test/input/func_noerror_encoding.py',
- 'test/input/func_unknown_encoding.py',)
try:
# python3
from distutils.command.build_py import build_py_2to3 as build_py
@@ -52,9 +49,6 @@ try:
if self.packages:
self.build_packages()
self.build_package_data()
- # filter test files
- self.updated_files = [f for f in self.updated_files
- if not f.endswith(P3K_FILES_TO_IGNORE)]
# 2to3
self.run_2to3(self.updated_files)
# Remaining base class code
@@ -104,8 +98,7 @@ def get_packages(directory, prefix):
for package in os.listdir(directory):
absfile = join(directory, package)
if isdir(absfile):
- if exists(join(absfile, '__init__.py')) or \
- package in ('test', 'tests'):
+ if exists(join(absfile, '__init__.py')):
if prefix:
result.append('%s.%s' % (prefix, package))
else: