summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorT.Rzepka <Tobias.Rzepka@gmail.com>2013-09-21 22:51:43 +0200
committerT.Rzepka <Tobias.Rzepka@gmail.com>2013-09-21 22:51:43 +0200
commit8c1788f1cec10a874aa5f398832f71d98e44c366 (patch)
treef919cc5de4ed37aa25992b2274c536c82803563c /setup.py
parentedcddebadd990e43a30f7a07b8efca0a02646964 (diff)
downloadpylint-8c1788f1cec10a874aa5f398832f71d98e44c366.tar.gz
#51: Building pylint Windows installer for Python3 fails
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 078eab0..f208216 100644
--- a/setup.py
+++ b/setup.py
@@ -121,6 +121,12 @@ class MyInstallLib(install_lib.install_lib):
base = join(subpackage_of, modname)
else:
base = modname
+ if sys.platform == 'win32':
+ two_to_three = [sys.executable]
+ exe_path = os.path.dirname(sys.executable)
+ two_to_three.append(os.path.join(exe_path, 'Tools\\Scripts\\2to3.py'))
+ else:
+ two_to_three = ['2to3']
for directory in include_dirs:
dest = join(self.install_dir, base, directory)
if sys.version_info >= (3, 0):
@@ -135,7 +141,7 @@ class MyInstallLib(install_lib.install_lib):
# process manually python file in include_dirs (test data)
from subprocess import call
print('running 2to3 on', dest)
- call(['2to3', '-wn', dest])
+ call(two_to_three + ['-wn', dest])
def install(**kwargs):