summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorClaudiu Popa <cpopa@cloudbasesolutions.com>2015-03-26 20:21:25 +0200
committerClaudiu Popa <cpopa@cloudbasesolutions.com>2015-03-26 20:21:25 +0200
commitb2c5965f961aa2130b7e747628203f1c4091bc88 (patch)
tree4c4ef1e8060b68f8e600d1af2a2e19f3d6cf193f /setup.py
parent899aaf10c5105f1b87066c9be22ece913ad7edd9 (diff)
downloadpylint-b2c5965f961aa2130b7e747628203f1c4091bc88.tar.gz
Finish converting tests to work both on Python 2 and 3. Also, drop 2to3 for tests.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 0 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 2abfada..77b6ea3 100644
--- a/setup.py
+++ b/setup.py
@@ -115,12 +115,6 @@ class MyInstallLib(install_lib.install_lib):
shutil.rmtree(dest, ignore_errors=True)
shutil.copytree(directory, dest,
ignore=shutil.ignore_patterns(*exclude))
- if sys.version_info >= (3, 0):
- # process manually python file in include_dirs (test data)
- # pylint: disable=no-name-in-module
- from distutils.util import run_2to3
- print(('running 2to3 on', dest))
- run_2to3([dest])
# override this since pip/easy_install attempt to byte compile test data
# files, some of them being syntactically wrong by design, and this scares