summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEmile Anclin <emile.anclin@logilab.fr>2010-12-16 11:27:56 +0100
committerEmile Anclin <emile.anclin@logilab.fr>2010-12-16 11:27:56 +0100
commite530f14b1f91fba8c3e1ce532620335048db7299 (patch)
treef3892d6404d0c435fcf635857a5a2f63f7faf08b /setup.py
parent99141ab45c884671823131aebc2cc4d11ba0ab5d (diff)
downloadpylint-e530f14b1f91fba8c3e1ce532620335048db7299.tar.gz
py3k packaging: remove removed files from P3K_FILES_TO_IGNORE
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 3 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 6149616..a764d2e 100644
--- a/setup.py
+++ b/setup.py
@@ -39,10 +39,8 @@ except ImportError:
USE_SETUPTOOLS = 0
# pylint needs to filter some test files expected to be wrong
-P3K_FILES_TO_IGNORE= ['test/input/func_wrong_encoding.py',
- 'test/input/func_noerror_encoding.py',
- 'test/input/func_unknown_encoding.py',
- 'test/input/func_nonascii_noencoding.py']
+P3K_FILES_TO_IGNORE= ('test/input/func_noerror_encoding.py',
+ 'test/input/func_unknown_encoding.py',)
try:
# python3
from distutils.command.build_py import build_py_2to3 as build_py
@@ -56,7 +54,7 @@ try:
self.build_package_data()
# filter test files
self.updated_files = [f for f in self.updated_files
- if not f.endswith(tuple(P3K_FILES_TO_IGNORE))]
+ if not f.endswith(P3K_FILES_TO_IGNORE)]
# 2to3
self.run_2to3(self.updated_files)
# Remaining base class code