summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJay Hutchinson <jlhutch@gmail.com>2011-07-23 02:21:41 -0500
committerJay Hutchinson <jlhutch@gmail.com>2011-07-23 02:21:41 -0500
commit57ce78406d76c0c2c26f7b4a938d06bb2379830e (patch)
tree39896b703b099b6052aa26e0bc73abaa65abfba0
parentc1536c5c425408df5a3f52511a47433051634385 (diff)
downloadpylru-57ce78406d76c0c2c26f7b4a938d06bb2379830e.tar.gz
Bump version to 1.0.4v1.0.4
-rw-r--r--README.txt6
-rw-r--r--setup.py2
2 files changed, 4 insertions, 4 deletions
diff --git a/README.txt b/README.txt
index 4eb2384..ed0ce33 100644
--- a/README.txt
+++ b/README.txt
@@ -92,7 +92,7 @@ Lrucache takes an optional callback function as a second argument. Since the cac
# know.
WriteThroughCacheManager
-========================
+------------------------
Often a cache is used to speed up access to some other high latency object. For example, imagine you have a backend storage object that reads/writes from/to a remote server. Let us call this object *store*. If store has a dictionary interface a cache manager class can be used to compose the store object and an lrucache. The manager object exposes a dictionary interface. The programmer can then interact with the manager object as if it were the store. The manager object takes care of communicating with the store and caching key/value pairs in the lrucache object.
@@ -138,7 +138,7 @@ The WriteThroughCacheManager class takes as arguments the store object you want
WriteBackCacheManager
-=====================
+---------------------
Similar to the WriteThroughCacheManager class except write-back semantics are used to manage the cache. The programmer is responsible for one more thing as well. They MUST call sync() when they are finished. This ensures that the last of the "dirty" entries in the cache are written back. This is not too bad as WriteBackCacheManager objects can be used in with statements. More about that below::
@@ -204,7 +204,7 @@ To help the programmer ensure that the final sync() is called, WriteBackCacheMan
lrudecorator
-============
+------------
PyLRU also provides a function decorator::
diff --git a/setup.py b/setup.py
index 6308daf..ca48a30 100644
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,7 @@ from distutils.core import setup
setup(
name = "pylru",
- version = "1.0.3",
+ version = "1.0.4",
py_modules=['pylru'],
description = "A least recently used (LRU) cache implementation",
author = "Jay Hutchinson",