summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Gordon <jogo@pinterest.com>2022-09-21 13:42:17 -0700
committerJoe Gordon <jogo@pinterest.com>2022-09-21 13:42:17 -0700
commit20e9911d23058c3a9c0deb510749f2edcf62eeb4 (patch)
treedb7cddcf595ffa509408bdfc6877eb4ac8bda86e
parent4940034c01e8440bf18e4b86619631779c7624c7 (diff)
downloadpymemcache-20e9911d23058c3a9c0deb510749f2edcf62eeb4.tar.gz
Add py.typed file
As per https://peps.python.org/pep-0561/ add a py.typed file to let things like mypy there is inline typing information
-rw-r--r--MANIFEST.in1
-rw-r--r--pymemcache/py.typed0
2 files changed, 1 insertions, 0 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 6e9e934..ddb59d2 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,5 +1,6 @@
include README.* ChangeLog.* setup.py setup.cfg LICENSE.txt
include *-requirements.txt tox.ini
+include pymemcache/py.typed
recursive-include pymemcache *.py
recursive-include pymemcache/test *.crt
recursive-include pymemcache/test *.key
diff --git a/pymemcache/py.typed b/pymemcache/py.typed
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/pymemcache/py.typed