summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Parise <jon@pinterest.com>2018-08-31 08:14:04 -0700
committerJon Parise <jon@pinterest.com>2018-08-31 08:14:04 -0700
commite24599c3ec27abc43c8cf232ba02b5cd694c9455 (patch)
treea8d75e67e63a99ee33fc9468698df7531ef78089
parent8339ff2f46ff44c3abc726b90a3cd29f8ed56966 (diff)
downloadpymemcache-e24599c3ec27abc43c8cf232ba02b5cd694c9455.tar.gz
Add official Python 3.7 support
Travis's default base image doesn't support Python 3.7 very well so we need to explicitly select the xenial distribution with sudo enabled.
-rw-r--r--.gitignore1
-rw-r--r--.travis.yml6
-rw-r--r--setup.py1
-rw-r--r--tox.ini4
4 files changed, 9 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index de971d8..4e66d05 100644
--- a/.gitignore
+++ b/.gitignore
@@ -23,6 +23,7 @@ env/
# Unit test / coverage reports
.coverage
+.pytest_cache
.tox
#Translations
diff --git a/.travis.yml b/.travis.yml
index 91cd5ed..d07f611 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -10,7 +10,11 @@ matrix:
- python: 3.5
env: TOXENV=py35
- python: 3.6
- env: TOXENV=py36,py36-flake8
+ env: TOXENV=py36
+ - python: 3.7
+ env: TOXENV=py37,py37-flake8
+ dist: xenial
+ sudo: true
- python: pypy
env: TOXENV=pypy
- python: pypy3
diff --git a/setup.py b/setup.py
index 9049669..c95bc15 100644
--- a/setup.py
+++ b/setup.py
@@ -30,6 +30,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: PyPy',
'License :: OSI Approved :: Apache Software License',
'Topic :: Database',
diff --git a/tox.ini b/tox.ini
index 2a9eee1..4c0bf26 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27, py34, py35, py36, pypy, pypy3, py27-flake8, py36-flake8, integration
+envlist = py27, py34, py35, py36, py37, pypy, pypy3, py27-flake8, py37-flake8, integration
skip_missing_interpreters = True
[testenv]
@@ -19,7 +19,7 @@ commands =
pip install flake8
flake8 pymemcache/
-[testenv:py36-flake8]
+[testenv:py37-flake8]
commands =
pip install flake8
flake8 pymemcache/