summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohn Anderson <sontek@gmail.com>2015-07-02 10:39:43 -0700
committerJohn Anderson <sontek@gmail.com>2015-07-02 10:39:43 -0700
commitcff5abfad59baa593996fe7e240fd3944e2c4af2 (patch)
tree5f91ba8f0c04790309b4b00027810da749025369 /setup.py
parenta935261830671ba84e8c15f1c9f031512e926338 (diff)
downloadpymemcache-cff5abfad59baa593996fe7e240fd3944e2c4af2.tar.gz
Remove dependency on clandestined and use pure python murmur3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index f053090..9183a9d 100644
--- a/setup.py
+++ b/setup.py
@@ -1,16 +1,16 @@
#!/usr/bin/env python
from setuptools import setup, find_packages
-
from pymemcache import __version__
+
setup(
name='pymemcache',
version=__version__,
author='Charles Gordon',
author_email='charles@pinterest.com',
packages=find_packages(),
- install_requires=['six', 'clandestined'],
+ install_requires=['six'],
description='A comprehensive, fast, pure Python memcached client',
long_description=open('README.md').read(),
license='Apache License 2.0',
@@ -20,6 +20,9 @@ setup(
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: PyPy',
+ 'Programming Language :: Python :: PyPy3',
'License :: OSI Approved :: Apache Software License',
'Topic :: Database',
],