summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-05-21 16:54:51 -0400
committerMonty Taylor <mordred@inaugust.com>2013-05-21 16:59:38 -0400
commit24bd40737ac97ad32226fbd29b50fda05de00364 (patch)
tree9e5f508133be95fe69ff39a5a5b723021139e5a8 /tox.ini
parentde1221109c28331684ed4d56913ee6d7541b0cc1 (diff)
downloadpymox-24bd40737ac97ad32226fbd29b50fda05de00364.tar.gz
Updated to use OpenStack standards.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini27
1 files changed, 27 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..2b30581
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,27 @@
+[tox]
+envlist = py26,py27,pep8
+
+[testenv]
+setenv = VIRTUAL_ENV={envdir}
+deps = -r{toxinidir}/requirements.txt
+ -r{toxinidir}/test-requirements.txt
+commands =
+ python tools/patch_tox_venv.py
+ python setup.py testr --slowest --testr-args='{posargs}'
+
+[testenv:pep8]
+commands = flake8
+
+[testenv:venv]
+commands = {posargs}
+
+[testenv:cover]
+setenv = VIRTUAL_ENV={envdir}
+commands =
+ python setup.py testr --coverage
+
+[flake8]
+show-source = true
+ignore = H,E11
+builtins = _
+exclude=.git,.tox,dist,doc,*openstack/common*,*lib/python*,*egg