summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2015-05-05 13:32:26 -0500
committerPaul Kehrer <paul.l.kehrer@gmail.com>2015-05-05 13:32:26 -0500
commit5992c07884cf6342d4ce6a294e9d994bb07984c0 (patch)
tree9b6001762e44ccaf4f4ef1c47e8ce640f92d9b5f
parent44b305e42e2cc906812e35d2b2cac44f4e8ff120 (diff)
parent59365192ca43539f6526a698bd3455f1d058a811 (diff)
downloadpyopenssl-5992c07884cf6342d4ce6a294e9d994bb07984c0.tar.gz
Merge pull request #254 from hynek/kill-stale-todo
Kill stale todo
-rw-r--r--.travis.yml8
-rw-r--r--MANIFEST.in5
-rw-r--r--TODO8
-rw-r--r--tox.ini8
4 files changed, 17 insertions, 12 deletions
diff --git a/.travis.yml b/.travis.yml
index 9c91b2f..59c7f90 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -44,6 +44,14 @@ matrix:
packages:
- libssl-dev/lucid
+ # Meta
+ - python: "2.7"
+ env: TOXENV=check-manifest
+
+ - python: "2.7"
+ env: TOXENV=pypi-readme
+
+
# Let the cryptography master builds fail because they might be triggered by
# cryptography changes beyond our control.
# Also allow OS X and 0.9.8 to fail at the moment while we fix these new
diff --git a/MANIFEST.in b/MANIFEST.in
index 455af6d..7b6f3e7 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,8 +1,7 @@
-include LICENSE ChangeLog TODO MANIFEST.in OpenSSL/RATIONALE *.rst tox.ini memdbg.py runtests.py OpenSSL/test/README
-exclude leakcheck
+include LICENSE ChangeLog MANIFEST.in *.rst tox.ini memdbg.py runtests.py OpenSSL/test/README
+exclude leakcheck
recursive-include doc *
recursive-include examples *
recursive-include rpm *
recursive-exclude leakcheck *.py *.pem
-global-exclude *.pyc
prune doc/_build
diff --git a/TODO b/TODO
deleted file mode 100644
index cbcf642..0000000
--- a/TODO
+++ /dev/null
@@ -1,8 +0,0 @@
-TODO list
-
-* Think more carefully about the relation between X509 and X509_NAME
- _set_{subject,issuer} dup the new name and free the old one.
-* Consider Pyrex
-* Updated docs! (rpm, ...)
-* _Somehow_ get makefile to work!
-* httpslib, imapslib, ftpslib?
diff --git a/tox.ini b/tox.ini
index e836692..1db296a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = {pypy,py26,py27,py32,py33,py34}{,-cryptographyMaster},pypi-readme
+envlist = {pypy,py26,py27,py32,py33,py34}{,-cryptographyMaster},pypi-readme,check-manifest
[testenv]
deps =
@@ -21,3 +21,9 @@ deps =
readme
commands =
python setup.py check -r -s
+
+[testenv:check-manifest]
+deps =
+ check-manifest
+commands =
+ check-manifest