summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHynek Schlawack <hs@ox.cx>2015-04-13 22:18:25 -0400
committerHynek Schlawack <hs@ox.cx>2015-04-13 22:50:59 -0400
commitb1648591f5dc621972e478df7c5d1711878fb5f8 (patch)
tree94684754ec70595dfd8d20e1e2e455591ca1f1a4
parent10a9d3b0035bf6c1f6a0da4f8c1e31260f4b91ab (diff)
downloadpyopenssl-b1648591f5dc621972e478df7c5d1711878fb5f8.tar.gz
Fix setup.py & MANIFEST.in
-rw-r--r--MANIFEST.in4
-rwxr-xr-xsetup.py4
2 files changed, 6 insertions, 2 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 31cf021..455af6d 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,6 +1,8 @@
-include LICENSE ChangeLog INSTALL.rst README TODO MANIFEST.in OpenSSL/RATIONALE
+include LICENSE ChangeLog TODO MANIFEST.in OpenSSL/RATIONALE *.rst tox.ini memdbg.py runtests.py OpenSSL/test/README
+exclude leakcheck
recursive-include doc *
recursive-include examples *
recursive-include rpm *
+recursive-exclude leakcheck *.py *.pem
global-exclude *.pyc
prune doc/_build
diff --git a/setup.py b/setup.py
index 65a1b52..839626a 100755
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,9 @@ setup(name='pyOpenSSL', version=__version__,
'OpenSSL.test.util',
'OpenSSL.test.test_crypto',
'OpenSSL.test.test_rand',
- 'OpenSSL.test.test_ssl'],
+ 'OpenSSL.test.test_ssl',
+ 'OpenSSL.test.test_tsafe',
+ 'OpenSSL.test.test_util',],
description = 'Python wrapper module around the OpenSSL library',
author = 'Jean-Paul Calderone',
author_email = 'exarkun@twistedmatrix.com',