summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@twistedmatrix.com>2014-01-11 14:47:35 -0500
committerJean-Paul Calderone <exarkun@twistedmatrix.com>2014-01-11 14:47:35 -0500
commit11b20594535ddb984a82507c8dba94092a364062 (patch)
treeb3cd3cff07468085567285cea431a5aff75164d0 /setup.py
parent19ad371f113be59b36b02b3e5ff73bf713906923 (diff)
parentadd057026d4e6fb3e3fbabc1fdde7b656e850925 (diff)
downloadpyopenssl-11b20594535ddb984a82507c8dba94092a364062.tar.gz
Merge remote-tracking branch 'pyca/master' into release-0.14
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 95d8635..5ae8038 100755
--- a/setup.py
+++ b/setup.py
@@ -8,7 +8,7 @@
Installation script for the OpenSSL module
"""
-from distutils.core import setup
+from setuptools import setup
# XXX Deduplicate this
__version__ = '0.14a1'
@@ -34,6 +34,7 @@ setup(name='pyOpenSSL', version=__version__,
maintainer_email = 'exarkun@twistedmatrix.com',
url = 'https://github.com/pyca/pyopenssl',
license = 'APL2',
+ install_requires=["cryptography>=0.1", "six>=1.5.2"],
long_description = """\
High-level wrapper around a subset of the OpenSSL library, includes
* SSL.Connection objects, wrapping the methods of Python's portable
@@ -57,4 +58,5 @@ High-level wrapper around a subset of the OpenSSL library, includes
'Topic :: Security :: Cryptography',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: System :: Networking',
- ])
+ ],
+ test_suite="OpenSSL")