summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2019-12-14 11:15:47 -0500
committerPaul Kehrer <paul.l.kehrer@gmail.com>2019-12-15 00:15:47 +0800
commit1ede58449a42f23b140022db2e6ec656c44b2780 (patch)
tree145fd3f51371a71f8fca934fff7fec3dca00318a /setup.py
parent26f1a920acea2da4ca23cf19cb3635be86c650c9 (diff)
downloadpyopenssl-1ede58449a42f23b140022db2e6ec656c44b2780.tar.gz
Drop support for Python 3.4, since cryptography dropped it (#884)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3e76199..e98c41e 100755
--- a/setup.py
+++ b/setup.py
@@ -77,7 +77,6 @@ if __name__ == "__main__":
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
@@ -89,6 +88,7 @@ if __name__ == "__main__":
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: System :: Networking',
],
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*',
packages=find_packages(where="src"),
package_dir={"": "src"},