summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@twistedmatrix.com>2014-01-10 14:09:20 -0500
committerJean-Paul Calderone <exarkun@twistedmatrix.com>2014-01-10 14:09:20 -0500
commit5d97b41cc68f05b63137622b2e6d2398834ba583 (patch)
treeb95a37f7132f4158b9e0e5748bd1c8af2e0dda4b /setup.py
parent558b78a781045aaccb291c9a7d48804ed1727ea1 (diff)
downloadpyopenssl-5d97b41cc68f05b63137622b2e6d2398834ba583.tar.gz
Use setuptools and declare the cryptography dependency
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c1bde55..078646b 100755
--- a/setup.py
+++ b/setup.py
@@ -8,7 +8,7 @@
Installation script for the OpenSSL module
"""
-from distutils.core import setup
+from setuptools import setup
# XXX Deduplicate this
__version__ = '0.13'
@@ -34,6 +34,7 @@ setup(name='pyOpenSSL', version=__version__,
maintainer_email = 'exarkun@twistedmatrix.com',
url = 'https://github.com/pyca/pyopenssl',
license = 'APL2',
+ install_requires=["cryptography>=0.1"],
long_description = """\
High-level wrapper around a subset of the OpenSSL library, includes
* SSL.Connection objects, wrapping the methods of Python's portable