summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2021-03-10 22:35:24 +0100
committerGitHub <noreply@github.com>2021-03-10 15:35:24 -0600
commit5dc698861c91b4aa83b284b282c0e91cdcee49a3 (patch)
treed98c73d18f263a76f0b10c7c75d1ea26d4ac858c /setup.py
parentd290855aab9f12d7cf739c63aad9ca3699d936f7 (diff)
downloadpyopenssl-5dc698861c91b4aa83b284b282c0e91cdcee49a3.tar.gz
Add SSL_CTX_set_min_proto_version/SSL_CTX_set_max_proto_version bindings (#985)
* add Context.set_*_proto_version, fix #860 * docs: add new openssl tls methods * accept the fact that nothing can be taken for granted * bump minimum required cryptography version to 3.3 * drop support for Python 3.5 * use binary wheels for cryptography * Revert "use binary wheels for cryptography" This reverts commit 91a04c612ed1d0dd9fd541dfefe21cac7c25b1c1. * docker ci: compile cryptography with rust
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index fbd6571..1ca7b11 100755
--- a/setup.py
+++ b/setup.py
@@ -79,7 +79,6 @@ if __name__ == "__main__":
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
@@ -90,12 +89,14 @@ if __name__ == "__main__":
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: System :: Networking",
],
- python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*",
+ python_requires=(
+ ">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*,!=3.5.*"
+ ),
packages=find_packages(where="src"),
package_dir={"": "src"},
install_requires=[
# Fix cryptographyMinimum in tox.ini when changing this!
- "cryptography>=3.2",
+ "cryptography>=3.3",
"six>=1.5.2",
],
extras_require={