summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@twistedmatrix.com>2013-02-09 09:03:18 -0800
committerJean-Paul Calderone <exarkun@twistedmatrix.com>2013-02-09 09:03:18 -0800
commit8210b921ca89775b8773d03123fee77c7fad99e5 (patch)
treeb668e5681b9e79d227cb10e892278d25400a870a /setup.py
parent54cc3906ad27da084d2c6409cf1c630c9af39ede (diff)
downloadpyopenssl-8210b921ca89775b8773d03123fee77c7fad99e5.tar.gz
Re-implement OpenSSL.rand in Python using opentls.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 511c60c..142d03c 100755
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,6 @@ crypto_dep = ['OpenSSL/crypto/crypto.h', 'OpenSSL/crypto/x509.h',
'OpenSSL/crypto/pkcs12.h', 'OpenSSL/crypto/netscape_spki.h',
'OpenSSL/crypto/revoked.h', 'OpenSSL/crypto/crl.h',
'OpenSSL/util.h']
-rand_src = ['OpenSSL/rand/rand.c', 'OpenSSL/util.c']
rand_dep = ['OpenSSL/util.h']
ssl_src = ['OpenSSL/ssl/connection.c', 'OpenSSL/ssl/context.c', 'OpenSSL/ssl/ssl.c',
'OpenSSL/ssl/session.c', 'OpenSSL/util.c']
@@ -195,9 +194,9 @@ def mkExtension(name):
setup(name='pyOpenSSL', version=__version__,
packages = ['OpenSSL'],
package_dir = {'OpenSSL': 'OpenSSL'},
- ext_modules = [mkExtension('crypto'), mkExtension('rand'),
- mkExtension('SSL')],
+ ext_modules = [mkExtension('crypto'), mkExtension('SSL')],
py_modules = ['OpenSSL.__init__', 'OpenSSL.tsafe',
+ 'OpenSSL.rand',
'OpenSSL.version', 'OpenSSL.test.__init__',
'OpenSSL.test.util',
'OpenSSL.test.test_crypto',