summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2019-11-18 09:20:29 +0800
committerAlex Gaynor <alex.gaynor@gmail.com>2019-11-17 20:20:29 -0500
commit8543286168ed3bb234395d66fb401714495ff198 (patch)
treee0bc1e55dae0e6722a01885d206747bd9e46bbbb /setup.py
parentfc802df5c10f0d1cd9749c94887d652fa26db6fb (diff)
downloadpyopenssl-8543286168ed3bb234395d66fb401714495ff198.tar.gz
bump the minimum cryptography version (#875)
Users with older cryptography (and hence potentially older asn1crypto, a transitive dependency) are seeing a serious bug on macOS catalina due to the way older asn1crypto loads a shared library. While this isn't a pyOpenSSL bug bumping this dep might prevent the bug from impacting some users.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f6d5499..3e76199 100755
--- a/setup.py
+++ b/setup.py
@@ -94,7 +94,7 @@ if __name__ == "__main__":
package_dir={"": "src"},
install_requires=[
# Fix cryptographyMinimum in tox.ini when changing this!
- "cryptography>=2.3",
+ "cryptography>=2.8",
"six>=1.5.2"
],
extras_require={