summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorzooko <zooko@yukyuk>2008-12-01 09:22:02 -0700
committerzooko <zooko@yukyuk>2008-12-01 09:22:02 -0700
commita4be22af9b16022cb58c2cdb97c0e06ff40f07d2 (patch)
tree18debbf51b4054cd540816a839ce370af29ce9cf /setup.py
parent3594e21509d8e7ab6f89358876e75a731d5f3a38 (diff)
downloadpyopenssl-a4be22af9b16022cb58c2cdb97c0e06ff40f07d2.tar.gz
convenience hack: if setuptools is not already present, then this will download it from pypi into the CWD and use it.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 343235c..c5c0247 100755
--- a/setup.py
+++ b/setup.py
@@ -11,6 +11,13 @@
Installation script for the OpenSSL module
"""
+try:
+ from ez_setup import use_setuptools
+except ImportError:
+ pass
+else:
+ use_setuptools(download_delay=0)
+
import os, sys
def pylibdir(prefixdir):