summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNathaniel J. Smith <njs@pobox.com>2021-11-01 23:30:36 -0700
committerGitHub <noreply@github.com>2021-11-02 14:30:36 +0800
commite84e7b57d1838de70ab7a27089fbee78ce0d2106 (patch)
tree9b5fa35e68396ac8c1ba7fbe208062a725323b77 /setup.py
parentea90b55c84ec25fcd725fe42573e93be5497158e (diff)
downloadpyopenssl-e84e7b57d1838de70ab7a27089fbee78ce0d2106.tar.gz
Expose some DTLS-related features (#1026)
* Expose DTLS_METHOD and friends * Expose OP_NO_RENEGOTIATION * Expose DTLS MTU-related functions * Expose DTLSv1_listen and associated callbacks * Add a basic DTLS test * Cope with old versions of openssl/libressl * blacken * Soothe flake8 * Add temporary hack to skip DTLS test on old cryptography versions * Update for cryptography v35 release * Add changelog entry * Fix versionadded:: * get_cleartext_mtu doesn't exist on decrepit old openssl * Rewrite DTLS test to work around stupid OpenSSL misbehavior * flake8 go away * minor tidying
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 85c4569..ecc23cc 100755
--- a/setup.py
+++ b/setup.py
@@ -93,7 +93,7 @@ if __name__ == "__main__":
package_dir={"": "src"},
install_requires=[
# Fix cryptographyMinimum in tox.ini when changing this!
- "cryptography>=3.3",
+ "cryptography>=35.0",
],
extras_require={
"test": ["flaky", "pretend", "pytest>=3.0.1"],