summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2022-09-16 23:55:17 +0200
committerGitHub <noreply@github.com>2022-09-16 16:55:17 -0500
commitf0ed288747a28a5785d7a62ef9e7afc699674625 (patch)
tree355b6d894d8f139f85823a6f71b19a1de9e12e90 /setup.py
parenta3483a7ad7415eb6037237b5261fb8a93e863589 (diff)
downloadpyopenssl-f0ed288747a28a5785d7a62ef9e7afc699674625.tar.gz
add `Connection.use_(certificate|privatekey)` (#1121)
* add `Connection.use_(certificate|privatekey)` * bump minimum cryptography version * deduplicate tests * black! * max line length
Diffstat (limited to 'setup.py')
-rw-r--r--[-rwxr-xr-x]setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9faee63..67e018b 100755..100644
--- a/setup.py
+++ b/setup.py
@@ -96,7 +96,7 @@ if __name__ == "__main__":
package_dir={"": "src"},
install_requires=[
# Fix cryptographyMinimum in tox.ini when changing this!
- "cryptography>=37.0.2,<39",
+ "cryptography>=38.0.0,<39",
],
extras_require={
"test": ["flaky", "pretend", "pytest>=3.0.1"],