summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHynek Schlawack <hs@ox.cx>2017-11-28 09:45:14 +0100
committerAlex Chan <alex@alexwlchan.net>2017-11-28 08:45:14 +0000
commitf724786613f90eb6e6ea26f4dbe17a1cda238d1e (patch)
treefea5c2de44720313f1fd4a3d607728aab52d365e /setup.py
parent736c62111550972d835e33a3084c3bfc37bb61f7 (diff)
downloadpyopenssl-f724786613f90eb6e6ea26f4dbe17a1cda238d1e.tar.gz
Pin pytest until we drop 2.6 (#721)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 13188ef..937d556 100755
--- a/setup.py
+++ b/setup.py
@@ -102,7 +102,9 @@ if __name__ == "__main__":
"test": [
"flaky",
"pretend",
- "pytest>=3.0.1",
+ # pytest 3.3 doesn't support Python 2.6 anymore.
+ # Remove this pin once we drop Python 2.6 too.
+ "pytest>=3.0.1,<3.3.0",
],
"docs": [
"sphinx",