summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2020-07-23 20:40:46 -0400
committerGitHub <noreply@github.com>2020-07-23 19:40:46 -0500
commit037371861693f26297320dcd5fd8c221b6d8df26 (patch)
treeab18ca46617b0036e137cd6a154726acbab36bdf /tox.ini
parent4ca4fb9e8ed3c45f09efab8269e4078d40f39d9b (diff)
downloadpyopenssl-037371861693f26297320dcd5fd8c221b6d8df26.tar.gz
Paint it Black by the Rolling Stones (#920)
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini11
1 files changed, 9 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index bdda806..5fc6ebb 100644
--- a/tox.ini
+++ b/tox.ini
@@ -52,11 +52,14 @@ commands =
rm -rf ./urllib3
[testenv:flake8]
+basepython = python3
deps =
- flake8
+ black
+ flake8
skip_install = true
commands =
- flake8 src tests setup.py
+ black --check .
+ flake8 src tests setup.py
[testenv:pypi-readme]
deps =
@@ -85,3 +88,7 @@ skip_install = true
commands =
coverage combine
coverage report
+
+[flake8]
+ignore = E203,W503,W504
+select = E,W,F,I