summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2022-05-12 06:33:36 +0800
committerGitHub <noreply@github.com>2022-05-11 18:33:36 -0400
commit069909af77171b1d925aed6cefe168a7e5e50f50 (patch)
treed31027412aa19a4c33832cc23b5f0d5e5d156792 /tox.ini
parent5a30471edc26efd38cb052d1ed923f2626e60c45 (diff)
downloadpyopenssl-069909af77171b1d925aed6cefe168a7e5e50f50.tar.gz
repair CI (#1116)
* repair CI * more fixes * pypy39 requires latest cryptography * Apply suggestions from code review Co-authored-by: Alex Gaynor <alex.gaynor@gmail.com> * use constant * bump minimum version * remove unneeded try * fix Co-authored-by: Alex Gaynor <alex.gaynor@gmail.com>
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini11
1 files changed, 2 insertions, 9 deletions
diff --git a/tox.ini b/tox.ini
index 93432dc..1c99fcb 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = {pypy,pypy3,py36,py37,py38,py39,py310}{,-cryptographyMain,-cryptographyMinimum}{,-useWheel}{,-randomorder},py37-twistedTrunk,pypi-readme,check-manifest,flake8,docs,coverage-report
+envlist = {pypy,pypy3,py36,py37,py38,py39,py310}{,-cryptographyMain,-cryptographyMinimum}{,-useWheel}{,-randomorder},py37-twistedTrunk,check-manifest,flake8,docs,coverage-report
[testenv]
whitelist_externals =
@@ -10,7 +10,7 @@ extras =
deps =
coverage>=4.2
cryptographyMain: git+https://github.com/pyca/cryptography.git
- cryptographyMinimum: cryptography==35.0
+ cryptographyMinimum: cryptography==37.0.2
randomorder: pytest-randomly
setenv =
# Do not allow the executing environment to pollute the test environment
@@ -44,13 +44,6 @@ commands =
black --check .
flake8 .
-[testenv:pypi-readme]
-deps =
- readme_renderer
-skip_install = true
-commands =
- python setup.py check -r -s
-
[testenv:check-manifest]
deps =
check-manifest