summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorLaurens Van Houtven <_@lvh.io>2015-04-20 10:19:33 -0700
committerLaurens Van Houtven <_@lvh.io>2015-04-20 10:19:33 -0700
commit1c855cb5c6e8cf4cb0558dc4aa7a74a621cda3d6 (patch)
tree48065ae9d00921631da8bd8dd7aff273f2a72ba6 /tox.ini
parentade80a175d231d3f6347364c5a318571ded4d6bd (diff)
parent9a2c732e5102bf03845f79d8271f7b66021200f6 (diff)
downloadpyopenssl-1c855cb5c6e8cf4cb0558dc4aa7a74a621cda3d6.tar.gz
Merge branch 'master' into test-metadata
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini12
1 files changed, 8 insertions, 4 deletions
diff --git a/tox.ini b/tox.ini
index 39bcf09..66cdf09 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,13 +1,18 @@
[tox]
-envlist = pypy,py26,py27,py32,py33,meta
+envlist = pypy,py26,py27,py32,py33,py34,meta
[testenv]
+deps =
+ setuptools>=7.0 # older setuptools pollute CWD with egg files of dependencies
+ coverage
setenv =
# Do not allowed the executing environment to pollute the test environment
# with extra packages.
PYTHONPATH=
-# The standard library unittest module can run tests on Python 2.7 and newer
-commands = python setup.py test
+commands =
+ python -c "import OpenSSL.SSL; print(OpenSSL.SSL.SSLeay_version(OpenSSL.SSL.SSLEAY_VERSION))"
+ coverage run --branch --source=OpenSSL setup.py test
+ coverage report -m
[testenv:meta]
deps =
@@ -23,4 +28,3 @@ commands =
# return 0, causing tox to believe it failed.
# https://bitbucket.org/regebro/pyroma/issue/18
sh -c <<EOT {envbindir}/pyroma . || (( $? == 1 )) EOT
-whitelist_externals = sh \ No newline at end of file