summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorChristian Clauss <cclauss@me.com>2020-11-29 22:46:45 +0100
committerGitHub <noreply@github.com>2020-11-29 15:46:45 -0600
commitac6868147999f98878e2237596f01bc771e80556 (patch)
treedf39fa42dee94e46da7d5fa14bf571675664b761 /tox.ini
parent1eb6766d9b4eff07aa6165af4d12d64e8f49e0f2 (diff)
downloadpyopenssl-ac6868147999f98878e2237596f01bc771e80556.tar.gz
Tox.ini; Test on Python 3.9 and make flake8 stricter (#966)
* Tox.ini; Test on Python 3.9 and make flake8 stricter * max-line-length = 88 * Remove unused import * Update tox.ini * Use PEP8 line length * Use PEP8 line length
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini5
1 files changed, 2 insertions, 3 deletions
diff --git a/tox.ini b/tox.ini
index a338c94..90a4c6a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = {pypy,pypy3,py27,py35,py36,py37,py38}{,-cryptographyMaster,-cryptographyMinimum}{,-randomorder},py37-twistedMaster,pypi-readme,check-manifest,flake8,docs,coverage-report
+envlist = {pypy,pypy3,py27,py35,py36,py37,py38,py39}{,-cryptographyMaster,-cryptographyMinimum}{,-randomorder},py37-twistedMaster,pypi-readme,check-manifest,flake8,docs,coverage-report
[testenv]
whitelist_externals =
@@ -40,7 +40,7 @@ deps =
skip_install = true
commands =
black --check .
- flake8 src tests setup.py
+ flake8 .
[testenv:pypi-readme]
deps =
@@ -72,4 +72,3 @@ commands =
[flake8]
ignore = E203,W503,W504
-select = E,W,F,I