summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--OpenSSL/RATIONALE (renamed from src/RATIONALE)0
-rw-r--r--OpenSSL/__init__.py (renamed from __init__.py)0
-rw-r--r--OpenSSL/crypto/crl.c (renamed from src/crypto/crl.c)0
-rw-r--r--OpenSSL/crypto/crl.h (renamed from src/crypto/crl.h)0
-rw-r--r--OpenSSL/crypto/crypto.c (renamed from src/crypto/crypto.c)0
-rw-r--r--OpenSSL/crypto/crypto.h (renamed from src/crypto/crypto.h)0
-rw-r--r--OpenSSL/crypto/netscape_spki.c (renamed from src/crypto/netscape_spki.c)0
-rw-r--r--OpenSSL/crypto/netscape_spki.h (renamed from src/crypto/netscape_spki.h)0
-rw-r--r--OpenSSL/crypto/pkcs12.c (renamed from src/crypto/pkcs12.c)0
-rw-r--r--OpenSSL/crypto/pkcs12.h (renamed from src/crypto/pkcs12.h)0
-rw-r--r--OpenSSL/crypto/pkcs7.c (renamed from src/crypto/pkcs7.c)0
-rw-r--r--OpenSSL/crypto/pkcs7.h (renamed from src/crypto/pkcs7.h)0
-rw-r--r--OpenSSL/crypto/pkey.c (renamed from src/crypto/pkey.c)0
-rw-r--r--OpenSSL/crypto/pkey.h (renamed from src/crypto/pkey.h)0
-rw-r--r--OpenSSL/crypto/revoked.c (renamed from src/crypto/revoked.c)0
-rw-r--r--OpenSSL/crypto/revoked.h (renamed from src/crypto/revoked.h)0
-rw-r--r--OpenSSL/crypto/x509.c (renamed from src/crypto/x509.c)0
-rw-r--r--OpenSSL/crypto/x509.h (renamed from src/crypto/x509.h)0
-rw-r--r--OpenSSL/crypto/x509ext.c (renamed from src/crypto/x509ext.c)0
-rw-r--r--OpenSSL/crypto/x509ext.h (renamed from src/crypto/x509ext.h)0
-rw-r--r--OpenSSL/crypto/x509name.c (renamed from src/crypto/x509name.c)0
-rw-r--r--OpenSSL/crypto/x509name.h (renamed from src/crypto/x509name.h)0
-rw-r--r--OpenSSL/crypto/x509req.c (renamed from src/crypto/x509req.c)0
-rw-r--r--OpenSSL/crypto/x509req.h (renamed from src/crypto/x509req.h)0
-rw-r--r--OpenSSL/crypto/x509store.c (renamed from src/crypto/x509store.c)0
-rw-r--r--OpenSSL/crypto/x509store.h (renamed from src/crypto/x509store.h)0
-rw-r--r--OpenSSL/pymemcompat.h (renamed from src/pymemcompat.h)0
-rw-r--r--OpenSSL/rand/rand.c (renamed from src/rand/rand.c)0
-rwxr-xr-xOpenSSL/ssl/connection.c (renamed from src/ssl/connection.c)0
-rw-r--r--OpenSSL/ssl/connection.h (renamed from src/ssl/connection.h)0
-rw-r--r--OpenSSL/ssl/context.c (renamed from src/ssl/context.c)0
-rw-r--r--OpenSSL/ssl/context.h (renamed from src/ssl/context.h)0
-rw-r--r--OpenSSL/ssl/ssl.c (renamed from src/ssl/ssl.c)0
-rw-r--r--OpenSSL/ssl/ssl.h (renamed from src/ssl/ssl.h)0
-rw-r--r--OpenSSL/util.c (renamed from src/util.c)0
-rw-r--r--OpenSSL/util.h (renamed from src/util.h)0
-rwxr-xr-xsetup.py42
37 files changed, 21 insertions, 21 deletions
diff --git a/src/RATIONALE b/OpenSSL/RATIONALE
index a0e389c..a0e389c 100644
--- a/src/RATIONALE
+++ b/OpenSSL/RATIONALE
diff --git a/__init__.py b/OpenSSL/__init__.py
index 6f393ff..6f393ff 100644
--- a/__init__.py
+++ b/OpenSSL/__init__.py
diff --git a/src/crypto/crl.c b/OpenSSL/crypto/crl.c
index 8e1c135..8e1c135 100644
--- a/src/crypto/crl.c
+++ b/OpenSSL/crypto/crl.c
diff --git a/src/crypto/crl.h b/OpenSSL/crypto/crl.h
index 87f5048..87f5048 100644
--- a/src/crypto/crl.h
+++ b/OpenSSL/crypto/crl.h
diff --git a/src/crypto/crypto.c b/OpenSSL/crypto/crypto.c
index d9f1a4e..d9f1a4e 100644
--- a/src/crypto/crypto.c
+++ b/OpenSSL/crypto/crypto.c
diff --git a/src/crypto/crypto.h b/OpenSSL/crypto/crypto.h
index 057b5dd..057b5dd 100644
--- a/src/crypto/crypto.h
+++ b/OpenSSL/crypto/crypto.h
diff --git a/src/crypto/netscape_spki.c b/OpenSSL/crypto/netscape_spki.c
index 4fa9d8d..4fa9d8d 100644
--- a/src/crypto/netscape_spki.c
+++ b/OpenSSL/crypto/netscape_spki.c
diff --git a/src/crypto/netscape_spki.h b/OpenSSL/crypto/netscape_spki.h
index 19389d8..19389d8 100644
--- a/src/crypto/netscape_spki.h
+++ b/OpenSSL/crypto/netscape_spki.h
diff --git a/src/crypto/pkcs12.c b/OpenSSL/crypto/pkcs12.c
index 2302242..2302242 100644
--- a/src/crypto/pkcs12.c
+++ b/OpenSSL/crypto/pkcs12.c
diff --git a/src/crypto/pkcs12.h b/OpenSSL/crypto/pkcs12.h
index 3abfa52..3abfa52 100644
--- a/src/crypto/pkcs12.h
+++ b/OpenSSL/crypto/pkcs12.h
diff --git a/src/crypto/pkcs7.c b/OpenSSL/crypto/pkcs7.c
index 1cb0813..1cb0813 100644
--- a/src/crypto/pkcs7.c
+++ b/OpenSSL/crypto/pkcs7.c
diff --git a/src/crypto/pkcs7.h b/OpenSSL/crypto/pkcs7.h
index bdbb425..bdbb425 100644
--- a/src/crypto/pkcs7.h
+++ b/OpenSSL/crypto/pkcs7.h
diff --git a/src/crypto/pkey.c b/OpenSSL/crypto/pkey.c
index 583a2a1..583a2a1 100644
--- a/src/crypto/pkey.c
+++ b/OpenSSL/crypto/pkey.c
diff --git a/src/crypto/pkey.h b/OpenSSL/crypto/pkey.h
index 3ac7bde..3ac7bde 100644
--- a/src/crypto/pkey.h
+++ b/OpenSSL/crypto/pkey.h
diff --git a/src/crypto/revoked.c b/OpenSSL/crypto/revoked.c
index 3042c4d..3042c4d 100644
--- a/src/crypto/revoked.c
+++ b/OpenSSL/crypto/revoked.c
diff --git a/src/crypto/revoked.h b/OpenSSL/crypto/revoked.h
index fb85ac6..fb85ac6 100644
--- a/src/crypto/revoked.h
+++ b/OpenSSL/crypto/revoked.h
diff --git a/src/crypto/x509.c b/OpenSSL/crypto/x509.c
index daae351..daae351 100644
--- a/src/crypto/x509.c
+++ b/OpenSSL/crypto/x509.c
diff --git a/src/crypto/x509.h b/OpenSSL/crypto/x509.h
index 43e41eb..43e41eb 100644
--- a/src/crypto/x509.h
+++ b/OpenSSL/crypto/x509.h
diff --git a/src/crypto/x509ext.c b/OpenSSL/crypto/x509ext.c
index 90ef543..90ef543 100644
--- a/src/crypto/x509ext.c
+++ b/OpenSSL/crypto/x509ext.c
diff --git a/src/crypto/x509ext.h b/OpenSSL/crypto/x509ext.h
index f20e562..f20e562 100644
--- a/src/crypto/x509ext.h
+++ b/OpenSSL/crypto/x509ext.h
diff --git a/src/crypto/x509name.c b/OpenSSL/crypto/x509name.c
index 39fdcf8..39fdcf8 100644
--- a/src/crypto/x509name.c
+++ b/OpenSSL/crypto/x509name.c
diff --git a/src/crypto/x509name.h b/OpenSSL/crypto/x509name.h
index 362ce35..362ce35 100644
--- a/src/crypto/x509name.h
+++ b/OpenSSL/crypto/x509name.h
diff --git a/src/crypto/x509req.c b/OpenSSL/crypto/x509req.c
index 07bd44b..07bd44b 100644
--- a/src/crypto/x509req.c
+++ b/OpenSSL/crypto/x509req.c
diff --git a/src/crypto/x509req.h b/OpenSSL/crypto/x509req.h
index db8043c..db8043c 100644
--- a/src/crypto/x509req.h
+++ b/OpenSSL/crypto/x509req.h
diff --git a/src/crypto/x509store.c b/OpenSSL/crypto/x509store.c
index 16af3b0..16af3b0 100644
--- a/src/crypto/x509store.c
+++ b/OpenSSL/crypto/x509store.c
diff --git a/src/crypto/x509store.h b/OpenSSL/crypto/x509store.h
index 9ed5073..9ed5073 100644
--- a/src/crypto/x509store.h
+++ b/OpenSSL/crypto/x509store.h
diff --git a/src/pymemcompat.h b/OpenSSL/pymemcompat.h
index 24221ec..24221ec 100644
--- a/src/pymemcompat.h
+++ b/OpenSSL/pymemcompat.h
diff --git a/src/rand/rand.c b/OpenSSL/rand/rand.c
index e922e08..e922e08 100644
--- a/src/rand/rand.c
+++ b/OpenSSL/rand/rand.c
diff --git a/src/ssl/connection.c b/OpenSSL/ssl/connection.c
index 6ee484d..6ee484d 100755
--- a/src/ssl/connection.c
+++ b/OpenSSL/ssl/connection.c
diff --git a/src/ssl/connection.h b/OpenSSL/ssl/connection.h
index 4e1e4d2..4e1e4d2 100644
--- a/src/ssl/connection.h
+++ b/OpenSSL/ssl/connection.h
diff --git a/src/ssl/context.c b/OpenSSL/ssl/context.c
index ebaf164..ebaf164 100644
--- a/src/ssl/context.c
+++ b/OpenSSL/ssl/context.c
diff --git a/src/ssl/context.h b/OpenSSL/ssl/context.h
index b52acf1..b52acf1 100644
--- a/src/ssl/context.h
+++ b/OpenSSL/ssl/context.h
diff --git a/src/ssl/ssl.c b/OpenSSL/ssl/ssl.c
index 94d4844..94d4844 100644
--- a/src/ssl/ssl.c
+++ b/OpenSSL/ssl/ssl.c
diff --git a/src/ssl/ssl.h b/OpenSSL/ssl/ssl.h
index ba7ba8b..ba7ba8b 100644
--- a/src/ssl/ssl.h
+++ b/OpenSSL/ssl/ssl.h
diff --git a/src/util.c b/OpenSSL/util.c
index ae6ee5e..ae6ee5e 100644
--- a/src/util.c
+++ b/OpenSSL/util.c
diff --git a/src/util.h b/OpenSSL/util.h
index d1157a7..d1157a7 100644
--- a/src/util.h
+++ b/OpenSSL/util.h
diff --git a/setup.py b/setup.py
index 9cb4364..7dccff7 100755
--- a/setup.py
+++ b/setup.py
@@ -21,26 +21,26 @@ from distutils.command.build_ext import build_ext
from version import __version__
-crypto_src = ['src/crypto/crypto.c', 'src/crypto/x509.c',
- 'src/crypto/x509name.c', 'src/crypto/pkey.c',
- 'src/crypto/x509store.c', 'src/crypto/x509req.c',
- 'src/crypto/x509ext.c', 'src/crypto/pkcs7.c',
- 'src/crypto/pkcs12.c', 'src/crypto/netscape_spki.c',
- 'src/crypto/revoked.c', 'src/crypto/crl.c',
- 'src/util.c']
-crypto_dep = ['src/crypto/crypto.h', 'src/crypto/x509.h',
- 'src/crypto/x509name.h', 'src/crypto/pkey.h',
- 'src/crypto/x509store.h', 'src/crypto/x509req.h',
- 'src/crypto/x509ext.h', 'src/crypto/pkcs7.h',
- 'src/crypto/pkcs12.h', 'src/crypto/netscape_spki.h',
- 'src/crypto/revoked.h', 'src/crypto/crl.h',
- 'src/util.h']
-rand_src = ['src/rand/rand.c', 'src/util.c']
-rand_dep = ['src/util.h']
-ssl_src = ['src/ssl/connection.c', 'src/ssl/context.c', 'src/ssl/ssl.c',
- 'src/util.c']
-ssl_dep = ['src/ssl/connection.h', 'src/ssl/context.h', 'src/ssl/ssl.h',
- 'src/util.h']
+crypto_src = ['OpenSSL/crypto/crypto.c', 'OpenSSL/crypto/x509.c',
+ 'OpenSSL/crypto/x509name.c', 'OpenSSL/crypto/pkey.c',
+ 'OpenSSL/crypto/x509store.c', 'OpenSSL/crypto/x509req.c',
+ 'OpenSSL/crypto/x509ext.c', 'OpenSSL/crypto/pkcs7.c',
+ 'OpenSSL/crypto/pkcs12.c', 'OpenSSL/crypto/netscape_spki.c',
+ 'OpenSSL/crypto/revoked.c', 'OpenSSL/crypto/crl.c',
+ 'OpenSSL/util.c']
+crypto_dep = ['OpenSSL/crypto/crypto.h', 'OpenSSL/crypto/x509.h',
+ 'OpenSSL/crypto/x509name.h', 'OpenSSL/crypto/pkey.h',
+ 'OpenSSL/crypto/x509store.h', 'OpenSSL/crypto/x509req.h',
+ 'OpenSSL/crypto/x509ext.h', 'OpenSSL/crypto/pkcs7.h',
+ 'OpenSSL/crypto/pkcs12.h', 'OpenSSL/crypto/netscape_spki.h',
+ 'OpenSSL/crypto/revoked.h', 'OpenSSL/crypto/crl.h',
+ 'OpenSSL/util.h']
+rand_src = ['OpenSSL/rand/rand.c', 'OpenSSL/util.c']
+rand_dep = ['OpenSSL/util.h']
+ssl_src = ['OpenSSL/ssl/connection.c', 'OpenSSL/ssl/context.c', 'OpenSSL/ssl/ssl.c',
+ 'OpenSSL/util.c']
+ssl_dep = ['OpenSSL/ssl/connection.h', 'OpenSSL/ssl/context.h', 'OpenSSL/ssl/ssl.h',
+ 'OpenSSL/util.h']
IncludeDirs = None
LibraryDirs = None
@@ -198,7 +198,7 @@ def mkExtension(name):
setup(name='pyOpenSSL', version=__version__,
packages = ['OpenSSL'],
- package_dir = {'OpenSSL': '.'},
+ package_dir = {'OpenSSL': 'OpenSSL'},
ext_modules = [mkExtension('crypto'), mkExtension('rand'),
mkExtension('SSL')],
py_modules = ['OpenSSL.__init__', 'OpenSSL.tsafe',